Project

General

Profile

action #23906

action #23516: [sle][tw][x11regressions] Migrate x11regression cases of SLE to tumbleweed

[tw][desktop] Migrate regression-other test cases to Tumbleweed

Added by GraceWang almost 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
-
Start date:
2017-09-05
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

We should:

  1. Update the needles
  2. Update main.pm
  3. Create testsuite in o.o.o

Testsuite of regression-other:
BOOTFROM=c
HDD_1=%DISTRI%-%VERSION%-%ARCH%-%BUILD%-%DESKTOP%@%MACHINE%.qcow2
REGRESSION=other
START_AFTER_TEST=regression-installation

Including:

  • /x11regressions/tracker/prep_tracker
  • /x11regressions/tracker/tracker_starts
  • /x11regressions/tracker/tracker_searchall
  • /x11regressions/tracker/tracker_pref_starts
  • /x11regressions/tracker/tracker_open_apps
  • /x11regressions/tracker/tracker_by_command
  • /x11regressions/tracker/tracker_info
  • /x11regressions/tracker/tracker_search_in_nautilus
  • /x11regressions/tracker/tracker_mainmenu
  • /x11regressions/tracker/clean_tracker

Except:

  • x11regressions/shotwell/shotwell_import
  • x11regressions/shotwell/shotwell_edit
  • x11regressions/shotwell/shotwell_export
  • virtualization/yast_virtualization
  • virtualization/virtman_view

History

#1 Updated by qkzhu almost 3 years ago

  • Parent task set to #23516

#2 Updated by GraceWang almost 3 years ago

Port test suite regression-other to Tumbleweed

  • Extract load_x11regression_other to main_common
  • Update main.pm for both SLE and openSUSE
  • Add 2 new test cases cover basic testing for brasero and totem
  • Enable 1 test case for gnome-documents
  • Port 10 tracker cases to Tumbleweed
  • We should also add testsuite of regression-other to o3: BOOTFROM=c DESKTOP=gnome HDD_1=%DISTRI%-%VERSION%-%BUILD%-%ARCH%_for_regression.qcow2 REGRESSION=other START_AFTER_TEST=regression-installation

Results can be found:
SLE: http://10.67.17.21/tests/69#
TW: http://10.67.17.21/tests/72#

TestCases: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3526
Needles for TW: https://github.com/os-autoinst/os-autoinst-needles-opensuse/pull/263
Needles for SLE: https://gitlab.suse.de/openqa/os-autoinst-needles-sles/merge_requests/477

#3 Updated by okurz almost 3 years ago

  • Category set to New test

#4 Updated by yfjiang about 2 years ago

  • Assignee changed from GraceWang to yuanren10

Hi Ren Yuan,

Would you take care of this for TW please.

#5 Updated by yfjiang about 2 years ago

  • Subject changed from [tw][x11regressions] Migrate regression-other test cases to Tumbleweed to [tw][desktop] Migrate regression-other test cases to Tumbleweed

#6 Updated by yuanren10 about 2 years ago

Yes, I will take care of that. :)

#7 Updated by yuanren10 about 2 years ago

  • Status changed from New to In Progress

testsuites should add to o.o.o:
BOOT_HDD_IMAGE=1
DESKTOP=gnome
HDD_1=%DISTRI%-%VERSION%-%ARCH%-%BUILD%-%DESKTOP%@%MACHINE%.qcow2
REGRESSION=other
START_AFTER_TEST=create_hdd_gnome

Verification run:
create_hdd_gnome
qam-regression-other

Reference github:
PR#405

Note:
There are some cases different with osd#1883267, which is test on SLE.
For example, " shotwell", " virtualization", and parts of " tracker" not test on Tumbleweed. Because these cases only run under if (is_sle('>=12-sp2') && is_sle('<15')) in "lib/main_common.pm". And they didn't installed by default on Tumbleweed.

So, I will update lib/main_common.pm and install them to do the test if necessary.

#8 Updated by okurz almost 2 years ago

The test scenario has been added to the job group Development Tumbleweed . Please monitor the test cases there and make sure to move it to "openSUSE Tumbleweed" as soon as it is stable.

#9 Updated by yuanren10 almost 2 years ago

  • Status changed from In Progress to Resolved

#10 Updated by yfjiang almost 2 years ago

  • Status changed from Resolved to In Progress
  • Assignee changed from yuanren10 to zgao

Reopen the ticket since Zhiyuan will work on continuous working based on the latest TW and drive it to Tumbleweed job group from the Development job group.

#11 Updated by zgao almost 2 years ago

Two needles have to be updated according to my local verification run.

I need privilege to update the needles on o.o.o.

Would anyone grant me with the privilege please? Or please correct me if I misunderstood anything.

#12 Updated by yfjiang almost 2 years ago

zgao wrote:

Two needles have to be updated according to my local verification run.

I need privilege to update the needles on o.o.o.

Would anyone grant me with the privilege please? Or please correct me if I misunderstood anything.

Hi Zhiyuan,

It seems the http needs to prefix with the URI, otherwise, the progress.opensuse.org will append to that link.

okurz, Hi Oliver, is that possible for you to help on granting the permission? Thank you!

#13 Updated by zgao almost 2 years ago

  • Status changed from In Progress to Resolved

Two needles added for regression-other.

Action resolved according to verification run on o3

Thank you for granting me operator privilege.

#14 Updated by zgao almost 2 years ago

  • Status changed from Resolved to In Progress

yfjiang

As I think regression-other is fairly decent now, shall we possibly move regression-other from Development Tumbleweed to Tumbleweed please?

#15 Updated by okurz almost 2 years ago

makes sense to me :)

#16 Updated by zgao almost 2 years ago

  • Status changed from In Progress to Resolved

Moved from Development Tumbleweed to Tumbleweed.
Renamed to desktopapps-other.
O3 https://openqa.opensuse.org/tests/785101

Also available in: Atom PDF