Project

General

Profile

Actions

action #23370

closed

Variables ADDONSURL and SCC_ADDONS needs cleanup

Added by dasantiago about 6 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Enhancement to existing tests
Target version:
-
Start date:
2017-08-15
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

The variable SCC_ADDONS needs to be set. However only the variable ADDONSURL is set.
These two variables represent the same thing. This needs a code cleanup

openQA test in scenario sle-12-SP2-Server-DVD-Updates-x86_64-create_hdd_minimal_base+sdk@64bit fails in
releasenotes

Reproducible

Fails since (at least) Build 20170811-3

Expected result

Last good: 20170811-2 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 1 (0 open1 closed)

Related to openQA Tests - action #23376: [functional][y] Improve variable documentationResolvedriafarov2017-08-152018-10-09

Actions
Actions #1

Updated by okurz about 6 years ago

The variables SCC_ADDONS and ADDONSURL do not represent the same thing. the test variables do not have a better documentation than reading how they are used. The file "variables" inside the root dir of os-autoinst-distri-opensuse at least should list all variables but IMHO there is also no automatic check for that, help appreciated :-)

Actions #2

Updated by okurz about 6 years ago

  • Category changed from Bugs in existing tests to Enhancement to existing tests
Actions #3

Updated by okurz about 6 years ago

  • Related to action #23376: [functional][y] Improve variable documentation added
Actions #4

Updated by okurz over 5 years ago

  • Status changed from New to Rejected

No action since 9 months, no commitment by any team, no response on my #23370#note-1 , rejecting. Feel free to reopen if you think we should really do something about it but then please respond to #23370#note-1

Actions

Also available in: Atom PDF