Project

General

Profile

Actions

action #20498

closed

[qam] test fails in gnome_default_applications

Added by vsvecova almost 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-07-17
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Desktop-DVD-Updates-x86_64-qam-regression-gnome@64bit fails in
gnome_default_applications

.jpg file opens in Shotwell, rather than EOG Image viewer.
Not sure whether this is intended.

Reproducible

Fails since (at least) Build 20170613-1

Expected result

Last good: (unknown) (or more recent)
https://openqa.suse.de/tests/1062031#step/gnome_default_applications/25

Further details

Always latest result in this scenario: latest

Actions #1

Updated by coolo almost 7 years ago

  • Priority changed from Normal to High

The jpg's name is shotwell_test.jpg - so to me it sounds proper to open it in shotwell :)

Actions #2

Updated by coolo almost 7 years ago

And it seems to be a bit random, which is picked. 0718-3 had it different again.

Actions #3

Updated by yfjiang almost 7 years ago

I was trying to look in from Desktop side, but without system real status logs, it's hardly to tell what's wrong there.

The testing seems started with an qcow2 image directly, it's very slow when I download it, is there a fast
way I can access the failure system?

Actions #4

Updated by yfjiang almost 7 years ago

Hi vsvecova,

This sounds more like a product issue, would you help to file a bugzilla entry mentioning the SP2 is supposed to use eog as default jpg/png viewer while it appears not?

For openQA, via coolo's idea in irc, maybe it's worthy of update a shotwell needle to "workaround" the case by now.

Actions #5

Updated by lnussel almost 7 years ago

Probably related, /usr/share/applications/mimeinfo.cache is generated by update-desktop-database which dumps the entries from a hash table, ie random order.

The second mechanism is /usr/bin/suse-update-mime-defaults updating /var/cache/gio-2.0 based on /etc/gnome_defaults.conf

Actions #6

Updated by pluskalm almost 7 years ago

  • Assignee set to dasantiago
Actions #7

Updated by pluskalm almost 7 years ago

Tracked in bsc#1051183

Actions #8

Updated by dasantiago almost 7 years ago

  • % Done changed from 0 to 100
Actions #9

Updated by dasantiago almost 7 years ago

  • Status changed from New to In Progress
Actions #10

Updated by dasantiago almost 7 years ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF