Project

General

Profile

action #20064

[sles][functional][yast] Bring peace and order to autoyast profiles

Added by SLindoMansilla over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Infrastructure
Start date:
2017-06-26
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Description

The autoyast profiles are organized in an out-of-date directory structure. This has to be simplified in order to make the maintenance easier.

The autoyast profiles under gh#os-autoinst-distri-opensuse should only match opensuse/SLE-latest.

Some autoyast tests don't need the support server to run, they are only using it to download the necessary assets, and those can be put available for the job.

Tasks

  1. There is only one directory for autoyast profiles if they work for all sle versions
    • Name: "os-autoinst-distri-opensuse/data/autoyast".
    • Move all the profiles to that directory.
  2. The yast team should check which tests are actually important.
    • Delete the non-important rest.
  3. Look for the tests that doesn't need a support server to be performed.
    • Make then single machine testing where possible.

Related issues

Related to openQA Tests - coordination #18602: [sles][functional][epic]review existing autoyast tests (was: test fails in repos because ip and tar is not installed)Resolved2017-07-262017-10-11

Blocked by openQA Tests - action #17366: [sle][functional] Autoyast verify module is failingResolved2017-02-28

History

#1 Updated by okurz over 5 years ago

  • Related to coordination #18602: [sles][functional][epic]review existing autoyast tests (was: test fails in repos because ip and tar is not installed) added

#2 Updated by SLindoMansilla over 5 years ago

  • Blocked by action #17366: [sle][functional] Autoyast verify module is failing added

#3 Updated by riafarov over 5 years ago

Notes:
1) Rename test according to the comment in PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3200#issuecomment-312619313
So what we could do to make it more obvious is to keep the existing profile but rename the openQA test suite to state "mix_uid_and_non_uid…". Possibly add the test with duplicate uids to see that relevant error is shown.
2) In some profiles, e.g. autoyast_sle12sp2/sles12.xml we have path to script. So in case of moving files to folders with relevant names, we also need to adjust these.
3) Some scripts were improved and need to be merged to https://github.com/yast/aytests-tests repo, namely post_script.sh, http.sh

#4 Updated by SLindoMansilla over 5 years ago

  • Status changed from New to In Progress

Ask to riafarov

#5 Updated by SLindoMansilla over 5 years ago

  • Assignee changed from SLindoMansilla to riafarov

#6 Updated by riafarov over 5 years ago

  • Target version set to Milestone 9

#7 Updated by riafarov over 5 years ago

Tests settings improved. Ticket remains open as we plan to create test group which is separate for yast tests only.

#8 Updated by okurz over 5 years ago

  • Target version changed from Milestone 9 to Milestone 10

you probably mean "keep the existing autoyast regression" job group but clone it for sle15.

#9 Updated by riafarov over 5 years ago

To be honest we have quite some yast and autoyast tests in SLE Functional job group. So idea was to keep them all in one place. Cloning for SLE15 is part of it.

#10 Updated by riafarov over 5 years ago

  • Description updated (diff)
  • Status changed from In Progress to Resolved

Part with new job group will be aimed in related ticket: https://progress.opensuse.org/issues/18602
We moved all profiles which were copied from aytests repo to that repo, and they are part of yast team integration tests. SLE 12 profiles remain in autoyast_sle12 folder as long as they don't work on sle 15. If they do, they will be moved to autoyast directory, which contains profiles which suppose to work with all SLE versions.

Also available in: Atom PDF