Project

General

Profile

action #19536

[sle][functional] Test fails in apache_ssl because it takes to long to find a suitable prime number

Added by nicksinger over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-06-02
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-aarch64-textmode+proxy_SCC@aarch64 fails in
apache_ssl
Happens because gensslcert is not able to find two suiting primes as dhparams in 600 seconds and times out.

Reproducible

Fails since (at least) Build 0409 (current job)
Depends most likely heavily on worker load.

Expected result

Last good: 0407 (or more recent)
gensslcert is able to finish its generation process.

Further details

Always latest result in this scenario: latest

Suggestions

  • Quick fix would be to increase the timeout
  • Since generating dhparam's takes up much time, maybe it is a better idea to check the progress of it in some way. Checking for two asteriks (*) (means: openssl found a suitable prime) in the output should solve the problem and we can detect if openssl/gensslcert itself is maybe buggy (if it does not exit after printing two *)

Related issues

Has duplicate openQA Tests - action #17396: [sle][functional] gensslcert times out after 600s because it cannot find a suitable prime numberResolved2017-03-01

History

#1 Updated by nicksinger over 4 years ago

  • Status changed from New to Rejected

Timeout was discussed here https://progress.opensuse.org/issues/17396 so i reopen poo#17396 and close this one as duplicate

#2 Updated by nicksinger over 4 years ago

  • Related to action #17396: [sle][functional] gensslcert times out after 600s because it cannot find a suitable prime number added

#3 Updated by nicksinger over 4 years ago

  • Status changed from Rejected to New

Cannot reopen poo#17396 so lets continue hereā€¦

#4 Updated by nicksinger over 4 years ago

  • Related to deleted (action #17396: [sle][functional] gensslcert times out after 600s because it cannot find a suitable prime number)

#5 Updated by nicksinger over 4 years ago

  • Has duplicate action #17396: [sle][functional] gensslcert times out after 600s because it cannot find a suitable prime number added

#6 Updated by nicksinger over 4 years ago

  • Status changed from New to Rejected

Basically a dup of poo#17396

Also available in: Atom PDF