Project

General

Profile

action #18288

[sle][x11regressions] x11regressions_setup tries to run tests in fully loaded system

Added by osukup over 5 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-04-03
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Desktop-DVD-Updates-x86_64-qam-regression-installation@64bit fails in
x11regressions_setup

type_string logged but missing in SUT

09:11:58.6432 Debug: /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/x11regressions/x11regressions_setup.pm:21 called testapi::script_sudo
09:11:58.6432 19379 <<< testapi::type_string(string='clear
', max_interval=250, wait_screen_changes=0)
09:11:58.8037 Debug: /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/x11regressions/x11regressions_setup.pm:21 called testapi::script_sudo
09:11:58.8040 19379 <<< testapi::type_string(string='su -c \'chown bernhard /dev/ttyS0; echo 1491210718-$?- > /dev/ttyS0\'
', max_interval=250, wait_screen_changes=0)
09:12:00.5185 Debug: /var/lib/openqa/cache/openqa.suse.de/tests/sle/tests/x11regressions/x11regressions_setup.pm:21 called testapi::script_sudo
09:12:00.5188 19379 <<< testapi::assert_screen(mustmatch='password-prompt', timeout=30)
09:12:00.5460 19380 MATCH(password-prompt-20141126:0.00)
09:12:00.5665 19380 MATCH(password-prompt-20150730:0.00)

Reproducible

random ... (saw also in openSUSE:Leap tests)

Fails since (at least) Build 20170403-2 (current job)

also on earlier one already 20170331-3 but passed afterwards so sporadic.

Expected result

Last good: 20170403-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz over 5 years ago

  • Description updated (diff)

#2 Updated by okurz over 5 years ago

  • Project changed from openQA Tests to openQA Project
  • Subject changed from test fails in x11regressions_setup -- missing string (ninja back?) to [tools]test fails in x11regressions_setup -- missing string (ninja back?)
  • Category deleted (Bugs in existing tests)
  • Priority changed from Normal to High

#3 Updated by okurz over 5 years ago

  • Category set to Concrete Bugs

#4 Updated by coolo over 5 years ago

  • Project changed from openQA Project to openQA Tests
  • Subject changed from [tools]test fails in x11regressions_setup -- missing string (ninja back?) to x11regressions_setup tries to run tests in fully loaded system
  • Category deleted (Concrete Bugs)

Tests need to take care that the SUT is idle

09:11:43.5065 19379 >>> testapi::wait_idle: timed out after 5

#5 Updated by okurz over 5 years ago

  • Subject changed from x11regressions_setup tries to run tests in fully loaded system to [sle][x11regressions] x11regressions_setup tries to run tests in fully loaded system
  • Category set to Bugs in existing tests

#6 Updated by osukup about 5 years ago

https://openqa.suse.de/tests/865575 same problem sshxterm test

#7 Updated by SLindoMansilla almost 5 years ago

  • Description updated (diff)
  • Status changed from New to Rejected
  • Priority changed from High to Normal

Links are broken.

No recent example in the last 84 of 84 previous jobs: osd#1055416?limit_previous=400#previous

Also available in: Atom PDF