Project

General

Profile

Actions

action #18070

closed

[opensuse][leap][kernel][functional][tools] test fails in crash because it can not find the debuginfo package

Added by okurz almost 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
michalnowak
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-03-28
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-42.3-DVD-x86_64-extra_tests_in_textmode@64bit fails in
crash
as it can not find the corresponding debuginfo package.

Reproducible

Fails since Build 0142 reproducibly every time.

Expected result

Last good: 0140, see https://openqa.opensuse.org/tests/371157#step/crash/18 which successfully installed kernel-debuginfo-4.4.49-1.2

Problem

On screen there are warnings that the update repos appear outdated. Maybe this is acceptable because updates are probably so far only consisting of test updates.

As can be seen in https://openqa.opensuse.org/tests/376271#step/zypper_lr/7 the debug repo is the online repo, not the corresponding one from the snapshot so I assume that can work sometimes when the online repo has been updated by coincidence to the same version for kernel-default as used in the snapshot and fail in all other occurences.

Suggestion

  • Sync debug repo for testing and use that
  • Disable all online repos within test

Further details

Always latest result in this scenario: latest


Related issues 2 (0 open2 closed)

Related to openQA Tests - action #17926: [tools]Tumbleweed upgrade tests have download.o.o repos enabledRejected2017-03-23

Actions
Related to openQA Tests - coordination #17436: [tools][functional][y][epic] tests must not have access to published repos, e.g. download.o.o on Tumbleweed -> remove all references to download.o.o from repos during installation and afterwardsResolvedriafarov2018-02-122019-02-26

Actions
Actions #1

Updated by okurz almost 7 years ago

  • Related to action #17926: [tools]Tumbleweed upgrade tests have download.o.o repos enabled added
Actions #2

Updated by michalnowak almost 7 years ago

  • Assignee set to michalnowak
Actions #3

Updated by michalnowak almost 7 years ago

  • Status changed from New to Feedback
Actions #4

Updated by RBrownSUSE almost 7 years ago

Wont we also need test code to use these newly synced media?

Actions #6

Updated by lnussel almost 7 years ago

dup of #17436?

Actions #7

Updated by michalnowak almost 7 years ago

  • Is duplicate of coordination #17436: [tools][functional][y][epic] tests must not have access to published repos, e.g. download.o.o on Tumbleweed -> remove all references to download.o.o from repos during installation and afterwards added
Actions #8

Updated by michalnowak almost 7 years ago

  • Is duplicate of deleted (coordination #17436: [tools][functional][y][epic] tests must not have access to published repos, e.g. download.o.o on Tumbleweed -> remove all references to download.o.o from repos during installation and afterwards)
Actions #9

Updated by michalnowak almost 7 years ago

  • Related to coordination #17436: [tools][functional][y][epic] tests must not have access to published repos, e.g. download.o.o on Tumbleweed -> remove all references to download.o.o from repos during installation and afterwards added
Actions #10

Updated by michalnowak almost 7 years ago

  • Status changed from Feedback to Resolved

Correctly versioned kernel debufinfo is now being installed on openSUSE Leap & Tumbleweed:

https://openqa.opensuse.org/tests/381952
https://openqa.opensuse.org/tests/382343#step/crash/18

Actions

Also available in: Atom PDF