Project

General

Profile

action #17960

JavaScript errors shouldn't be silently ignored

Added by mkittler over 3 years ago. Updated 6 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2017-03-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Currently JavaScript errors in openQA are ignored and only visible when opening the development console in the web browser.

It would be useful if such errors would be

  1. visible to the user
  2. or logged on the server in case of failed API calls

instead of having no feedback at all.

In the second case the server could evaluate a referrer sent by the web UI to recognize failed API calls caused by the web UI specifically.

History

#1 Updated by coolo almost 3 years ago

  • Target version set to future

showing javascript errors to the user sounds insane. Logging to the server sounds far from trivial though - https://stackoverflow.com/questions/119432/logging-clientside-javascript-errors-on-server gives quite some hints.

And logging the error without knowing the details of the user's setup sounds unhelpful too - and refering our users to external logging services sounds overkill. So I'm undecided if this is a good idea at all.

#2 Updated by okurz over 2 years ago

  • Target version changed from future to future

#3 Updated by okurz 6 months ago

  • Status changed from New to Rejected
  • Assignee set to okurz

As we are "undecided if this is a good idea at all" and we didn't progress since 3 years I guess it's time to say that we don't need it.

Also available in: Atom PDF