Project

General

Profile

action #17916

[tools] openqa-worker produces an 503 error right after startup

Added by nicksinger over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Concrete Bugs
Target version:
-
Start date:
2017-03-23
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

observation

A openqa-worker instance shows a "503 - Service not available" error right after startup.
Here is a screenshot of this: http://10.162.31.103/tests/91#step/worker/7

steps to reproduce

  • Run the "openQA in openQA" test on a not so powerful machine
  • See how the startup of openqa-worker fails with a 503 error

problem

After a short talk to rbrown we came up with the idea that this is maybe an issue with the service file of openqa-(websockets|worker).
Most likely the worker wants to connect to the websockets service which is not available this fast right after bootup.

suggestion

If it is really an issue with the connection between openqa-websockets and openqa-worker, this could easily be fixed by adding openqa-websockets as dependency in the service-file of openqa-worker.

workaround

Obviously this issue does not appear on instances of openqa which are running on more powerful machines (like e.g. o3).
Maybe a sleep before the startup of openqa-worker is a suitable workaround but not tested yet by me.

History

#1 Updated by oholecek over 4 years ago

This test should be extended to gather some more logging. Anyway, this is not the websockets not connecting since worker doesn't dump the response in case of WS failure. Only inform user to check if wstunnel_proxy is enabled in apache. This is most probably openQA webui not yet ready to accept connections and apache worker is thus returning 503.

#2 Updated by coolo over 4 years ago

as the worker runs (potentionally) on a different host, systemd can't "solve" this. The worker will just reconnect later. So where is the bug?

You want to hide the error for how many minutes after boot up?

#3 Updated by nicksinger over 4 years ago

  • Status changed from New to Closed

In fact it is openqa-webui not starting up because of poo#17620.

Also available in: Atom PDF