Project

General

Profile

action #16638

[sles][sled][functional][migration] test fails in wireshark

Added by qkzhu almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-02-10
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Desktop-DVD-x86_64-migration_offline_sled11_sp4@64bit fails in
wireshark

This case failed at different steps:
https://openqa.suse.de/tests/767468#step/wireshark/44
https://openqa.suse.de/tests/767474#step/wireshark/23
https://openqa.suse.de/tests/767475#step/wireshark/71
https://openqa.suse.de/tests/767473#step/wireshark/42

Reproducible

Fails since (at least) Build 0111 (current job)

Expected result

Last good: 0110 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Has duplicate openQA Tests - action #18260: [sled][x11regressions]test fails in wiresharkResolved2017-04-01

History

#2 Updated by okurz almost 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: sdk+allpatterns
http://openqa.suse.de/tests/808629

#3 Updated by okurz almost 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: sdk+allpatterns
http://openqa.suse.de/tests/808629

#4 Updated by okurz almost 5 years ago

  • Subject changed from test fails in wireshark to [sled][migration] test fails in wireshark

#5 Updated by okurz almost 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: sdk+allpatterns
https://openqa.suse.de/tests/837208

#6 Updated by okurz almost 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: migration_offline_sled12sp2_fullupdate
https://openqa.suse.de/tests/878122

#7 Updated by qkzhu over 4 years ago

  • Assignee set to qkzhu

Previously this case was rather unstable, it often broke at different steps. Recently this case was blocked by poo#17896 which has been fixed now.
And it only failed once at: https://openqa.suse.de/tests/878122#step/wireshark/91

I will try to add a wait_still_screen before:
170 send_key "alt-f4";
171 assert_screen "wireshark-fullscreen";
172 send_key "alt-f4";

#8 Updated by qkzhu over 4 years ago

  • Status changed from New to In Progress

#9 Updated by qkzhu over 4 years ago

qkzhu wrote:

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2757

Verification test: http://147.2.212.103/tests/557#

Comments from the PR: There is new version (major version bump) of wireshark coming up, so I would suggest waiting for it to be released as this fix might be not needed.

Currently wireshark failed at the last few steps which is not critical, and it is not reproducible every time, so I will close this PR.

#10 Updated by qkzhu over 4 years ago

  • Has duplicate action #18260: [sled][x11regressions]test fails in wireshark added

#11 Updated by okurz over 4 years ago

  • Subject changed from [sled][migration] test fails in wireshark to [sles][sled][functional][migration] test fails in wireshark

https://openqa.suse.de/tests/897474#step/wireshark/26 looks like this issue as well. A dialog is opened which is unexpected but there have been no recent changes in the wireshark test nor the product in this regard.

#12 Updated by yfjiang over 4 years ago

okurz wrote:

https://openqa.suse.de/tests/897474#step/wireshark/26 looks like this issue as well. A dialog is opened which is unexpected but there have been no recent changes in the wireshark test nor the product in this regard.

It looks the "eth0" checkbox somehow was not checked on, causing the "Start" button not clickable.

IMHO, possibly there's some space to improve in -

assert_and_click "wireshark-interfaces";
send_key "spc";

#13 Updated by qkzhu over 4 years ago

okurz wrote:

It looks the "eth0" checkbox somehow was not checked on, causing the "Start" button not clickable.

IMHO, possibly there's some space to improve in -

assert_and_click "wireshark-interfaces";
send_key "spc";

I will try to add a wait_still_screen before send_key 'spc'.

#15 Updated by qkzhu over 4 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF