Project

General

Profile

Actions

action #16516

closed

[functional][sporadic][u][medium] test fails in vlc to open network dialog with "ctrl-n"

Added by okurz about 7 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Bugs in existing tests
Start date:
2017-02-06
Due date:
2018-05-22
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-42.3-DVD-x86_64-kde@USBboot_64 fails in
vlc
to show the network dialog which should have been opened by the "ctrl-n" hotkey.

Reproducible

Fails since (at least) Build 0077 (current job)
but seems to be sporadic.

Expected result

Last good: 0075 (or more recent)

Problem

H1. Hotkey is pressed "too early" and is lost

Suggestion

  • check statistics
  • guard the keypress with wait_screen_change/wait_still_screen or retry more than once?

Further details

Always latest result in this scenario: latest


Related issues 1 (0 open1 closed)

Related to openQA Tests - action #33523: [functional][wayland][opensuse][medium][u]VLC on Plasma/Wayland: input not finished before pressing 'play'Resolvedzluo2018-03-202018-06-19

Actions
Actions #1

Updated by okurz about 6 years ago

  • Subject changed from test fails in vlc to open network dialog with "ctrl-n" to [functional]test fails in vlc to open network dialog with "ctrl-n"
  • Target version set to Milestone 15
Actions #2

Updated by okurz almost 6 years ago

  • Due date set to 2018-04-10
Actions #3

Updated by okurz almost 6 years ago

  • Related to action #33523: [functional][wayland][opensuse][medium][u]VLC on Plasma/Wayland: input not finished before pressing 'play' added
Actions #4

Updated by okurz almost 6 years ago

  • Subject changed from [functional]test fails in vlc to open network dialog with "ctrl-n" to [functional][sporadic][u]test fails in vlc to open network dialog with "ctrl-n"
  • Status changed from New to Workable
Actions #5

Updated by okurz almost 6 years ago

  • Due date changed from 2018-04-10 to 2018-04-24

not enough capacity in S14, moving

Actions #6

Updated by okurz almost 6 years ago

  • Due date changed from 2018-04-24 to 2018-05-22
  • Target version changed from Milestone 15 to Milestone 16

not enough capacity in S15 nor S16, moving

Actions #7

Updated by riafarov almost 6 years ago

  • Subject changed from [functional][sporadic][u]test fails in vlc to open network dialog with "ctrl-n" to [functional][sporadic][u][medium] test fails in vlc to open network dialog with "ctrl-n"

Gather stats first and see if it's still an issue.

Actions #8

Updated by zluo almost 6 years ago

  • Assignee set to zluo

take over

Actions #9

Updated by zluo almost 6 years ago

  • Status changed from Workable to In Progress
Actions #10

Updated by zluo almost 6 years ago

we have a new issue which related to opening MRL. but the dialog itself could be opened anyway in recent test runs.

Actions #11

Updated by zluo almost 6 years ago

/var/lib/openqa/share/tests/opensuse/tests/x11/vlc.pm:

found that this causes problem:

type_string autoinst_url . "/data/Big_Buck_Bunny_8_seconds_bird_clip.ogv";
assert_and_click "vlc-play_button";

Try at first with wait_still_screen before assert_and_click.

Actions #12

Updated by zluo almost 6 years ago

it is safe to check URL input here before assert_and_click.

Actions #13

Updated by zluo almost 6 years ago

create a new needle to match ogv url before assert_and_click:

http://e13.suse.de/tests/2417

Actions #14

Updated by zluo almost 6 years ago

needle match is a problem since the after input of url, it differs a little bit :(

Actions #15

Updated by zluo almost 6 years ago

http://e13.suse.de/tests/2423#step/vlc/23

shows match for new needle. but later send_key "ctrl-q" doesn't close vlc...

Actions #16

Updated by zluo almost 6 years ago

http://e13.suse.de/tests/2429#step/vlc/26

alt-f4 added after ctrl-q, it works with closing vlc.

Actions #18

Updated by zluo almost 6 years ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF