Project

General

Profile

action #16368

Test fails in online_migration_setup

Added by mkravec almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-01-31
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Many jobs fail to boot (~19 in build Migration: Server build 0226)

This problem needs more investigation (boot with debug parameter..)

20:39:56.3390 8825 >>> testapi::_check_backend_response: match=displaymanager timed out after 200
20:39:56.4399 8825 <<< testapi::send_key(key='esc')
20:39:56.6431 8825 test online_migration_setup failed

Observation

openQA test in scenario sle-12-SP3-Server-DVD-x86_64-om_proxyscc_sles12_ha+we+allpatterns_minimal_patch_by_zypper@64bit fails in
online_migration_setup

Reproducible

Fails since (at least) Build 0209

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #16718: [migration]reduce and optimize amount of migration scenarios on o.s.d.Resolved2017-02-13

History

#1 Updated by mitiao almost 5 years ago

asmorodskyi submitted a PR to increase timeout for booting hdd:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2397

From the testing result after the PR merging, I think it makes little effect for the issue.
I assume that it is caused by IO stalled when multiple om testing are running in parallel on a same worker.
IO consuming is quite high during booting hdd.

#2 Updated by okurz almost 5 years ago

good point. I don't know how many of these jobs run in parallel but for the RAID tests we already put them in a series with START_AFTER to prevent the IO stalling. I recommend the same for some of the migration tests.

#3 Updated by mitiao almost 5 years ago

  • Related to action #16718: [migration]reduce and optimize amount of migration scenarios on o.s.d. added

#4 Updated by mitiao almost 5 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 70

Amount of proxyscc testings have been reduced by action #16718, fill the setting of START_AFTER_TEST to some om testings to try to prevent IO stalling.
And use the testings without addons that have higher success rate as the chain header to prevent failure of whole chain.

#5 Updated by mitiao almost 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 70 to 100

Resolved with adding START_AFTER_TEST on selected testings.

Also available in: Atom PDF