Project

General

Profile

Actions

action #156919

closed

[sporadic] test fails in start_test - openqa-cli api request to o3 itself often times out trying to get latest 'ping_client' auto_review:"openqa-cli api --host.*openqa.opensuse.org.*ping_client":retry size:S

Added by okurz 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2024-03-08
Due date:
2024-03-27
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario openqa-Tumbleweed-dev-x86_64-openqa_install_multimachine@64bit-4G fails in
start_test

Test died: command 'resp=$(OPENQA_CLI_RETRIES=5 openqa-cli api --host http://openqa.opensuse.org jobs version=Tumbleweed scope=relevant arch='x86_64' flavor=DVD test='ping_client' groupid=1 latest=1)' timed out at /usr/lib/os-autoinst/autotest.pm line 415.

Acceptance Criteria

  • AC1: Requests can handle temporarily unavailable connections

Reproducible

Fails since (at least) Build :TW.27072 (current job)

Expected result

Last good: :TW.27071 (or more recent)

Further details

Always latest result in this scenario: latest

Suggestions

  • Requests time out after 3s which is probably too short
  • Implement exponential back-off in openqa-cli
Actions #1

Updated by livdywan 2 months ago

  • Subject changed from [sporadic] test fails in start_test - openqa-cli api request to o3 itself often times out trying to get latest 'ping_client' auto_review:"openqa-cli api --host.*openqa.opensuse.org.*ping_client":retry to [sporadic] test fails in start_test - openqa-cli api request to o3 itself often times out trying to get latest 'ping_client' auto_review:"openqa-cli api --host.*openqa.opensuse.org.*ping_client":retry size:S
  • Description updated (diff)
  • Status changed from New to Workable
Actions #2

Updated by ybonatakis 2 months ago

  • Status changed from Workable to In Progress
  • Assignee set to ybonatakis
Actions #3

Updated by ybonatakis 2 months ago

Actions #4

Updated by ybonatakis 2 months ago

Actions #5

Updated by livdywan 2 months ago

  • Description updated (diff)

It was meant to say exponential. I mixed up the words.

Actions #6

Updated by openqa_review 2 months ago

  • Due date set to 2024-03-27

Setting due date based on mean cycle time of SUSE QE Tools

Actions #7

Updated by livdywan 2 months ago

ybonatakis wrote in #note-4:

or https://github.com/os-autoinst/openQA/pull/5506 for incremental timeout

Discussed the fix on workadventu.re and decided to drop the unit test due to issues with mocking. That can be improved later without blocking the fix.

Actions #8

Updated by okurz 2 months ago

  • Tags set to reactive work
Actions #9

Updated by ybonatakis 2 months ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF