Project

General

Profile

action #15536

openQA Project - action #9680: libvirt backend

action #10204: zKVM Tests

action #12330: Upgrades on s390

zKVM: Upgrades

Added by mgriessmeier over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Start date:
2016-12-16
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Subticket for https://progress.opensuse.org/issues/12330

PR's are merged, not deployed yet
After deployment I can say more about the status here


Checklist

  • PR: Backend and Tests can handle upgrades and booting existing images
  • Add tests to Test-Development
  • PR gets deployed
  • Move tests to acceptance group

History

#1 Updated by mgriessmeier over 5 years ago

  • Checklist item changed from to [ ] Add tests to Test-Development

#2 Updated by mgriessmeier over 5 years ago

  • Checklist item changed from to [x] Add tests to Test-Development

#3 Updated by mgriessmeier over 5 years ago

  • Checklist item changed from to [x] PR gets deployed

#4 Updated by mgriessmeier over 5 years ago

I've tried several attempts to reproduce this in my local instance, but failed

I was talking to coolo and most likely this will be fixed with a new deployment, but apparently this went terribly wrong - so I can't verify it at the moment

I'll suggest to move this to milestone 5

#5 Updated by okurz over 5 years ago

milestone 4 is due today, but today is not over ;-) We will review the milestone results next week. If it does not work until then we will discuss the plan.

#6 Updated by mgriessmeier over 5 years ago

  • Category set to New test
  • Target version changed from Milestone 4 to Milestone 5

not able to reproduce locally, will discuss more with coolo, but we suspect it as a product bug - so moving to Milestone 5

#7 Updated by mgriessmeier over 5 years ago

Update: After speaking with coolo about this again, we came to the conclusion that a retry of select_console most likely will solve this issue and it would also be close to what a customer would do (e.g. connecting with vncviewer is not working, so let's try it again...)
I'll come up with a solution for that, though testing might be difficult, since I can't reproduce it locally

#8 Updated by okurz over 5 years ago

uh, what was the last status about this one? https://openqa.suse.de/tests/754787/file/autoinst-log.txt shows

DIE Can't call method "blocking" on an undefined value at /usr/lib/os-autoinst/consoles/VNC.pm line 854.

 at /usr/lib/os-autoinst/backend/baseclass.pm line 73.
    backend::baseclass::die_handler('Can\'t call method "blocking" on an undefined value at /usr/l...') called at /usr/lib/os-autoinst/consoles/VNC.pm line 854
    consoles::VNC::_receive_message('consoles::VNC=HASH(0x70072d8)') called at /usr/lib/os-autoinst/consoles/VNC.pm line 772
    consoles::VNC::update_framebuffer('consoles::VNC=HASH(0x70072d8)') called at /usr/lib/os-autoinst/consoles/vnc_base.pm line 67
    consoles::vnc_base::request_screen_update('consoles::vnc_base=HASH(0x4b66280)') called at /usr/lib/os-autoinst/consoles/vnc_base.pm line 79
    consoles::vnc_base::current_screen('consoles::vnc_base=HASH(0x4b66280)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 573
    backend::baseclass::capture_screenshot('backend::svirt=HASH(0x5e46940)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 468
    backend::baseclass::select_console('backend::svirt=HASH(0x5e46940)', 'HASH(0x8195298)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 68
    backend::baseclass::handle_command('backend::svirt=HASH(0x5e46940)', 'HASH(0x6dd1f68)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 422
    backend::baseclass::check_socket('backend::svirt=HASH(0x5e46940)', 'IO::Handle=GLOB(0x5f9e760)', 0) called at /usr/lib/os-autoinst/backend/svirt.pm line 162
    backend::svirt::check_socket('backend::svirt=HASH(0x5e46940)', 'IO::Handle=GLOB(0x5f9e760)', 0) called at /usr/lib/os-autoinst/backend/baseclass.pm line 203
    eval {...} called at /usr/lib/os-autoinst/backend/baseclass.pm line 151
    backend::baseclass::run_capture_loop('backend::svirt=HASH(0x5e46940)') called at /usr/lib/os-autoinst/backend/baseclass.pm line 122
    backend::baseclass::run('backend::svirt=HASH(0x5e46940)', 6, 9) called at /usr/lib/os-autoinst/backend/driver.pm line 85
    backend::driver::start('backend::driver=HASH(0x4a5d850)') called at /usr/lib/os-autoinst/backend/driver.pm line 48
    backend::driver::new('backend::driver', 'svirt') called at /usr/bin/isotovideo line 197
    main::init_backend() called at /usr/bin/isotovideo line 268

#9 Updated by mgriessmeier over 5 years ago

hmm... actually this is new to me - but it's in there for a few builds now
I will have a look on it

#10 Updated by mgriessmeier over 5 years ago

So What I've found out:

  • Tests are failing on o.s.d which uses zKVM instances 3,4 and 5
  • Can't be reproduced locally on zKVM instance 6 and 7 but... I was able to reproduce it with my local setup when I use one of the o.s.d instances

which means that there is some misconfiguration on the zKVM Hypervisor which needs investigation

#11 Updated by okurz over 5 years ago

maybe use different tap devices

#12 Updated by mgriessmeier over 5 years ago

  • Target version changed from Milestone 5 to Milestone 6
  • I will check and try to use different tap devices

but for now, I will move this to Milestone 6, since there is a product bug atm and working on it might be more difficult

#14 Updated by mgriessmeier about 5 years ago

working test in test-development:
https://openqa.suse.de/tests/810561

#15 Updated by mgriessmeier about 5 years ago

I've moved those two migration jobs to the Migration group
migration_offline_sle12sp2-allpatterns
migration_offline_sle12sp2

and added those 3 to the Test-Development for the next steps
migration_offline_sle12sp1
migration_offline_sle12sp1_allpatterns

migration_offline_sle12sp1_ha

I consider this ticket as resolved, since the next steps are not about enabling it in general but to extend

#16 Updated by mgriessmeier about 5 years ago

  • Checklist item changed from [x] PR: Backend and Tests can handle upgrades and booting existing images, [x] Add tests to Test-Development, [x] PR gets deployed, [ ] Move tests to acceptance group to [x] PR: Backend and Tests can handle upgrades and booting existing images, [x] Add tests to Test-Development, [x] PR gets deployed, [x] Move tests to acceptance group
  • Status changed from In Progress to Resolved

Also available in: Atom PDF