Project

General

Profile

action #15466

Live view takes long time to load when there's more than two "viewers"

Added by szarate over 4 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Low
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2016-12-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

observation

When there are more than two browsers (say users) looking at a job's live view, the third one henceforth will take a noticeable time to load.

steps to reproduce

  1. Go to openqa.suse.de
  2. Go to All tests, and choose one running job, and open the live view
  3. Open again the live view for the same job 4 times

problem

Somehow the webUI is getting stalled trying to process the 3rd/4th request (Stalling on images mostly)

suggestion

Check the sub streaming lib/OpenQA/WebAPI/Controller/Running.pm

workaround

Have no more than two live views enabled.

Screenshot from 2016-12-13 10-31-44.png (212 KB) Screenshot from 2016-12-13 10-31-44.png Notice the time in liveterminal and event streamming szarate, 2016-12-13 09:33
2710

History

#1 Updated by okurz over 4 years ago

  • Category changed from Concrete Bugs to Feature requests
  • Priority changed from Normal to Low

Compared to the other issues we have I am sure you will agree this is low prio. And also I don't consider it a "concrete bug". It's a feature request. I guess multi-viewer mode was never specified properly.

#2 Updated by szarate over 4 years ago

  • Category changed from Feature requests to Concrete Bugs

I agree with the priority, but I don't see it as a feature request, the feature is already implemented and works, but also has a problem therefore it's a bug.

#3 Updated by coolo over 3 years ago

  • Assignee set to coolo
  • Target version set to future

I will work on the live view going forward

#4 Updated by coolo about 3 years ago

  • Status changed from New to Rejected

Can't reproduce - had 6 tabs open together with Rodion

#5 Updated by okurz about 3 years ago

  • Target version changed from future to future

Also available in: Atom PDF