Project

General

Profile

Actions

action #153325

closed

osd-deployment | Failed pipeline, Digest verification failed for openQA-common size:M

Added by nicksinger 5 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
2024-01-10
Due date:
% Done:

0%

Estimated time:

Description

Observation

https://gitlab.suse.de/openqa/osd-deployment/-/jobs/2147143 fails with:

    Warning: Digest verification failed for file 'openQA-common-4.6.1704466891.4d4e5b7-lp155.6263.1.aarch64.rpm'
    [/var/tmp/AP_0xu5QjCF/aarch64/openQA-common-4.6.1704466891.4d4e5b7-lp155.6263.1.aarch64.rpm]

      expected 54c424e19b97104953e5c1e28b81a291690a3e73f4ccc7705312ff0eb5f53cb8
      but got  e3117a0c9ad9cbf0dbc00d70ba6bfa304e9592a69d158f1e5b8561a71ece6094

This happened already 4 times. The only related thing I found on progress is https://progress.opensuse.org/issues/69334 so maybe an broken mirror?

Suggestions

  • Check the openQA OBS project if everything is fine or needs fixing
  • Make sure our automatic deployments are working again
  • Try to reproduce by running zypper manually on the worker host (maybe within a container)
  • Restart the deployment pipeline

Related issues 2 (0 open2 closed)

Related to openQA Infrastructure - action #153328: jenkins fails in submit-openQA-TW-to-oS_Fctry, Server returned an error: HTTP Error 400: Bad Request size:MResolvednicksinger2024-01-10

Actions
Related to openSUSE admin - tickets #69334: Problem with mirror replication?Resolvedcboltz2020-07-24

Actions
Actions #1

Updated by nicksinger 5 months ago

  • Copied to action #153328: jenkins fails in submit-openQA-TW-to-oS_Fctry, Server returned an error: HTTP Error 400: Bad Request size:M added
Actions #2

Updated by nicksinger 5 months ago

  • Copied to deleted (action #153328: jenkins fails in submit-openQA-TW-to-oS_Fctry, Server returned an error: HTTP Error 400: Bad Request size:M)
Actions #3

Updated by nicksinger 5 months ago

  • Related to action #153328: jenkins fails in submit-openQA-TW-to-oS_Fctry, Server returned an error: HTTP Error 400: Bad Request size:M added
Actions #4

Updated by okurz 5 months ago

  • Tags set to infra, osd, osd-deployment, reactive work
  • Priority changed from Normal to Urgent
  • Target version set to Ready
Actions #5

Updated by okurz 5 months ago

Actions #6

Updated by mkittler 5 months ago

  • Subject changed from osd-deployment | Failed pipeline, Digest verification failed for openQA-common to osd-deployment | Failed pipeline, Digest verification failed for openQA-common size:M
  • Description updated (diff)
  • Status changed from New to Workable
  • Assignee set to nicksinger
Actions #7

Updated by nicksinger 5 months ago

  • Status changed from Workable to In Progress
Actions #8

Updated by nicksinger 5 months ago

  • Status changed from In Progress to Resolved

Restarted the deployment pipeline and it works again so I assume some hickup in the OBS API somewhere. I can't come up with any improvement here.

Actions

Also available in: Atom PDF