Project

General

Profile

Actions

action #151340

open

[qe-core] test fails in disk_boot

Added by anag 3 months ago. Updated about 1 month ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2023-11-23
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Staging tests are running into this issue very often, usually it works after re-triggering but it's very annoying as you can imagine.

openQA test in scenario microos-Staging:J-Staging-MicroOS-Image-ContainerHost-x86_64-container-host@uefi-staging fails in
disk_boot

Test suite description

Reproducible

Fails since (at least) Build J.70.12 (current job)

Expected result

Last good: J.70.11 (or more recent)

Further details

Always latest result in this scenario: latest

Actions #2

Updated by maritawerner 3 months ago

  • Subject changed from test fails in disk_boot to [qe-core] test fails in disk_boot
Actions #3

Updated by mloviska about 1 month ago

jlausuch wrote in #note-1:

@mloviska could it be related to https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/18074 ?

I haven't touched ignition.qcow2 nor combustion.qcow2 the original ones from Fabian (IIRC).

--- >>>[   31.704604] localhost.localdomain combustion[1652]: umount: /sysroot/dev: target is busy. <<<---
[   31.704857] localhost.localdomain systemd[1]: sysroot-opt.mount: Deactivated successfully.
[   31.706306] localhost.localdomain systemd[1]: sysroot-boot-efi.mount: Deactivated successfully.
[   31.706455] localhost.localdomain systemd[1]: sysroot-home.mount: Deactivated successfully.
[   31.706554] localhost.localdomain systemd[1]: sysroot-.snapshots.mount: Deactivated successfully.
[   31.706648] localhost.localdomain systemd[1]: sysroot-dev-pts.mount: Deactivated successfully.
[   31.706826] localhost.localdomain systemd[1]: sysroot-dev-shm.mount: Deactivated successfully.
[   31.707236] localhost.localdomain systemd[1]: combustion.service: Main process exited, code=exited, status=32/n/a
[   31.721763] localhost.localdomain systemd[1]: combustion.service: Failed with result 'exit-code'.
[   31.730305] localhost.localdomain systemd[1]: Failed to start Combustion.

I have seen this target is busy problem in JeOS with combustion. Not directly visible over here as the test does not print content of /run/initramfs/rdsosreport.txt. It seems like a worker issue, changing to different worker helps.

Actions

Also available in: Atom PDF