Project

General

Profile

action #15118

Text is mistyped on aarch64

Added by mkravec about 6 years ago. Updated almost 6 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
2016-11-29
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Hostname test module fails to type network.service - types "netwwork" instead.

https://openqa.suse.de/tests/646967#step/hostname/13


Related issues

Related to openQA Project - coordination #14972: [tools][epic] Improvements on backend to improve better handling of stallsResolved2016-11-24

Is duplicate of openQA Tests - action #12250: [sporadic]"QEMU: usb-kbd: warning: key event queue full" on ppc64le and aarch64Resolved2016-06-03

History

#1 Updated by zluo about 6 years ago

  • Assignee set to zluo

check the current test and found the test looks good and mistyped string got changed:

https://openqa.suse.de/tests/654357
https://openqa.suse.de/tests/654357/modules/hostname/steps/1/src

#2 Updated by zluo about 6 years ago

  • Status changed from New to In Progress

#3 Updated by zluo about 6 years ago

  • Status changed from In Progress to Resolved

#4 Updated by mkravec almost 6 years ago

  • Subject changed from Service name is mistyped - netwwork.service to Text is mistyped on aarch64
  • Status changed from Resolved to New

Very similar issue appeared here: https://openqa.suse.de/tests/666025#step/yast2_i/3

#5 Updated by zluo almost 6 years ago

Checked test code, no type. So this is strange. I'll take care of this and run some tests to verify.

#6 Updated by zluo almost 6 years ago

  • Status changed from New to In Progress

start test again and it works for me. No issue with typo:

https://openqa.suse.de/tests/666550#step/yast2_i/3

#7 Updated by zluo almost 6 years ago

will check this for a couple of next runs from now...

#8 Updated by zluo almost 6 years ago

talked to Santiago, and we see that is server performance issue:

21:03:23.2333 7751 <<< testapi::type_string(string='zypper -n in yast2-packager; echo jsCbX-$?- > /dev/ttyAMA0', max_interval=250, wait_screen_changes=0)
21:03:27.3834 7752 QEMU: usb-kbd: warning: key event queue full
21:03:27.3835 7752 QEMU: usb-kbd: warning: key event queue full
21:03:27.3835 7752 QEMU: usb-kbd: warning: key event queue full
21:03:27.3835 7752 QEMU: usb-kbd: warning: key event queue full
21:03:27.3835 7752 QEMU: usb-kbd: warning: key event queue full
21:03:27.3836 7752 QEMU: usb-kbd: warning: key event queue full
21:03:27.3836 7752 QEMU: usb-kbd: warning: key event queue full
21:03:27.3836 7752 QEMU: usb-kbd: warning: key event queue full
21:03:27.3836 7752 QEMU: usb-kbd: warning: key event queue full
21:03:27.3838 Debug: /var/lib/openqa/share/tests/sle/tests/console/yast2_i.pm:28 called testapi::assert_script_run
21:03:27.3840 7751 <<< testapi::send_key(key='ret')
21:03:27.5914 Debug: /var/lib/openqa/share/tests/sle/tests/console/yast2_i.pm:28 called testapi::assert_script_run
21:03:27.5917 7751 <<< testapi::wait_serial(regexp='jsCbX-\d+-', timeout=90)
21:03:34.9240 7752 WARNING: enqueue_screenshot took 7.11 seconds - slow IO? (opencv: 0.02 - encoder: 7.10)
21:04:58.4869 7751 >>> testapi::wait_serial: jsCbX-\d+-: fail
21:04:58.4875 7751 # Test died: command 'zypper -n in yast2-packager' failed at /var/lib/openqa/share/tests/sle/tests/console/yast2_i.pm line 28.

#9 Updated by mkravec almost 6 years ago

This seems like duplicate of poo#12250 then.

#10 Updated by zluo almost 6 years ago

  • Status changed from In Progress to Rejected

yes, set is as duplicate of #12250

#11 Updated by szarate almost 6 years ago

  • Related to coordination #14972: [tools][epic] Improvements on backend to improve better handling of stalls added

#12 Updated by szarate almost 6 years ago

Left a comment on #12250, i'm not 100% sure that it's a duplicate yet, for now i'll asume yes until i can prove otherwise (Specially with this comment since it talks about the SUT having so many IO operations that it becomes unusable, rather than the worker becoming slow, e.g no slow IO messages).

#13 Updated by szarate almost 6 years ago

  • Is duplicate of action #12250: [sporadic]"QEMU: usb-kbd: warning: key event queue full" on ppc64le and aarch64 added

Also available in: Atom PDF