Project

General

Profile

Actions

action #138320

closed

test fail hook in openqa_webui is failing: script/opencli api jobs - Can't locate Mojo::Base in @INC

Added by livdywan 8 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2023-10-23
Due date:
% Done:

0%

Estimated time:

Description

Observation

openQA test in scenario openqa-Tumbleweed-dev-x86_64-openqa_from_git@64bit-2G fails in
openqa_webui

# script/opencli api jobs
wCan't locate Mojo::Base in @INC

The investigate jobs fail in different ways:

https://openqa.opensuse.org/tests/3664888

[2023-10-22T15:00:03.830633Z] [debug] [pid:93263] git hash in openqa: 3bc7a4b627ceba9a2e9f075295d126470fe39b38
[2023-10-22T15:00:03.851028Z] [info] [pid:93263] ::: OpenQA::Isotovideo::Utils::clone_git: Cloning git URL 'https://github.com/os-autoinst/os-autoinst-wheel-launcher.git' into '/var/lib/openqa/pool/8'
[2023-10-22T15:00:03.886082Z] [debug] [pid:93263] Cloning into 'os-autoinst-wheel-launcher'...
   fatal: unable to access 'https://github.com/os-autoinst/os-autoinst-wheel-launcher.git/': Recv failure: Connection reset by peer

[2023-10-22T15:00:03.886243Z] [debug] [pid:93263] Clone failed, retries left: 2 of 2
[2023-10-22T15:00:08.892492Z] [info] [pid:93263] ::: OpenQA::Isotovideo::Utils::clone_git: Cloning git URL 'https://github.com/os-autoinst/os-autoinst-wheel-launcher.git' into '/var/lib/openqa/pool/8'
[2023-10-22T15:00:08.930153Z] [debug] [pid:93263] Cloning into 'os-autoinst-wheel-launcher'...
   fatal: unable to access 'https://github.com/os-autoinst/os-autoinst-wheel-launcher.git/': Recv failure: Connection reset by peer

[2023-10-22T15:00:08.930282Z] [debug] [pid:93263] Clone failed, retries left: 1 of 2
[2023-10-22T15:00:13.935994Z] [info] [pid:93263] ::: OpenQA::Isotovideo::Utils::clone_git: Cloning git URL 'https://github.com/os-autoinst/os-autoinst-wheel-launcher.git' into '/var/lib/openqa/pool/8'
[2023-10-22T15:00:13.970518Z] [debug] [pid:93263] Cloning into 'os-autoinst-wheel-launcher'...
   fatal: unable to access 'https://github.com/os-autoinst/os-autoinst-wheel-launcher.git/': Recv failure: Connection reset by peer

[2023-10-22T15:00:13.970613Z] [debug] [pid:93263] Clone failed, retries left: 0 of 2
[2023-10-22T15:00:18.971041Z] [warn] [pid:93263] !!! main: Unable to clone Git repository 'https://github.com/os-autoinst/os-autoinst-wheel-launcher.git' specified via openqa/wheels.yaml (see log for details) at /usr/lib/os-autoinst/OpenQA/Isotovideo/Utils.pm line 56.

https://openqa.opensuse.org/tests/3664890#step/dashboard/4

Test died: no candidate needle with tag(s) 'desktop-runner, screenlock' matched

https://openqa.opensuse.org/tests/3664891 / https://openqa.opensuse.org/tests/3664889

[2023-10-22T15:00:39.200922Z] [debug] [pid:27430] fatal: remote error: upload-pack: not our ref bbf801599f8d6630c4b8c564473365375deb884f

[2023-10-22T15:00:39.201054Z] [debug] [pid:27430] Clone failed, retries left: 2 of 2
[2023-10-22T15:00:44.201377Z] [debug] [pid:27430] Skipping to clone 'https://github.com/os-autoinst/os-autoinst-distri-opensuse.git'; os-autoinst-distri-opensuse already exists
[2023-10-22T15:00:44.212271Z] [debug] [pid:27430] git hash in /var/lib/openqa/pool/1/os-autoinst-distri-opensuse: 065c4274184ef090642c946c982a4641e3fcf68d
[2023-10-22T15:00:44.213047Z] [warn] [pid:27430] !!! main: 'SCHEDULE' not set and ./main.pm not found, need one of both at /usr/lib/os-autoinst/OpenQA/Isotovideo/Utils.pm line 276.

Test suite description

Reproducible

Fails since (at least) Build :TW.23842 (current job)

Expected result

Last good: :TW.23841 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 1 (0 open1 closed)

Copied to QA - action #138491: tests fail in retry despite having successfully executed relevant commands such as git clone size:MResolvedosukup2023-10-232023-12-06

Actions
Actions #1

Updated by livdywan 8 months ago

  • Description updated (diff)
  • Target version changed from QE-Core: Ready to Ready
Actions #2

Updated by livdywan 8 months ago

  • Description updated (diff)
Actions #3

Updated by livdywan 8 months ago

  • Status changed from New to In Progress
  • Assignee set to livdywan

I'm confirming if this is reproducible and what to make of the investigation jobs including splitting those into other tickets.

Actions #4

Updated by maritawerner 8 months ago

  • Project changed from openQA Tests to openQA Infrastructure
  • Category deleted (Bugs in existing tests)
Actions #6

Updated by livdywan 8 months ago

  • Status changed from In Progress to Feedback
  • Priority changed from High to Normal

livdywan wrote in #note-5:

https://openqa.opensuse.org/tests/overview?build=poo%23138320&distri=openqa&version=Tumbleweed

https://openqa.opensuse.org/tests/overview?build=poo%23138320_&distri=openqa&version=Tumbleweed

Both the original and the latest build don't reproduce any issues... so maybe there's nothing we can do here...

Actions #7

Updated by tinita 8 months ago

I think the title is a bit misleading. Can't locate Mojo::Base in @INC.
That's just the post_fail_hook: https://github.com/os-autoinst/os-autoinst-distri-openQA/blob/master/lib/openQAcoretest.pm#L17
The failure was in the clone: https://openqa.opensuse.org/tests/3664877#step/openqa_webui/20

I think we should improve the post_fail_hook to check first whether openqa-cli / Mojo::Base exists, because I had been wondering about that error too, when I first saw it some time ago.

Actions #8

Updated by tinita 8 months ago

tinita wrote in #note-7:

I think we should improve the post_fail_hook to check first whether openqa-cli / Mojo::Base exists, because I had been wondering about that error too, when I first saw it some time ago.

Or even just overwrite post_fail_hook here to do nothing, because if it fails in the installation, openqa-cli won't be helpful anyway:
https://github.com/os-autoinst/os-autoinst-distri-openQA/blob/master/tests/install/openqa_webui.pm

Actions #9

Updated by livdywan 8 months ago

  • Subject changed from test fails in openqa_webui: script/opencli api jobs - Can't locate Mojo::Base in @INC to test fail hook in openqa_webui is failing: script/opencli api jobs - Can't locate Mojo::Base in @INC
Actions #10

Updated by livdywan 8 months ago

  • Copied to action #138491: tests fail in retry despite having successfully executed relevant commands such as git clone size:M added
Actions #11

Updated by livdywan 8 months ago

  • Status changed from Feedback to Blocked
  • From what we can confirm the cloning worked, and this is why script/openqa-cli exists and only fails in dependencies
    • retry still reports a failing result
    • Filed as #138491
  • We're assuming more retries would actually work around the bug in retry, @okurz is looking into that
  • The post fail hook ran into deps issues because cloning "failed"
    • This wouldn't be a problem in other cases of broken deps or installation failing as the error would in fact be visible

Let's block this on #138491

Actions #13

Updated by tinita 7 months ago

#138491 is being worked on and should be fixed soon

Actions #14

Updated by livdywan 6 months ago

  • Status changed from Blocked to Workable
  • Assignee deleted (livdywan)

Blocker's been resolved

Actions #15

Updated by tinita 5 months ago

It seems we never estimated this

Actions #16

Updated by livdywan 5 months ago

  • Status changed from Workable to New

tinita wrote in #note-15:

It seems we never estimated this

Ah. My mistake! It was Blocked, and I put it on Workable instead of New.

Actions #17

Updated by mkittler 5 months ago

It also doesn't look like this is a problem anymore.

Actions #18

Updated by okurz 5 months ago

  • Status changed from New to Rejected
  • Assignee set to okurz

That's what I also figured

Actions

Also available in: Atom PDF