action #13170

[qam] Mysql/Mariadb odbc integration tests

Added by scarabeus_iv over 3 years ago. Updated over 1 year ago.

Status:ResolvedStart date:
Priority:LowDue date:
Assignee:emiura% Done:

0%

Category:New test
Target version:QA - future
Difficulty:
Duration:

Description

mysql/mariadb and various ODBC drivers (unixODBC, MyODBC-unixODBC, ...)
- install mysql-community-server/mariadb and ODBC driver packages
- configure it (odbc.ini)
- verify database connection

History

#1 Updated by okurz about 3 years ago

  • Target version set to future

#2 Updated by okurz over 2 years ago

Do you have plans to work on this or what did you plan for this ticket?

#3 Updated by pluskalm over 2 years ago

  • Subject changed from Mysql/Mariadb odbc integration tests to [qam] Mysql/Mariadb odbc integration tests

#4 Updated by pluskalm over 2 years ago

  • Assignee changed from scarabeus_iv to emiura
  • Priority changed from Normal to Low
  • For details of expected test coveragecheck with mysql/mariadb maintainers (kstreitova) also check current php tests (in aggregate/mau-webserver tests - i.e https://openqa.suse.de/tests/1071945)

#5 Updated by emiura over 2 years ago

  • Status changed from New to In Progress

#6 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: qam-minimal+base
https://openqa.suse.de/tests/1207751

#7 Updated by emiura over 2 years ago

Need to make it work on platforms !x86_64. Also have to address the lack of mysql_odbc plugin on some version.

#8 Updated by emiura over 2 years ago

  • Status changed from In Progress to Resolved

Fixed on commit 4f28bd30224af73f370836a5e5fb97d394ed0f53

#9 Updated by okurz over 1 year ago

  • Target version changed from future to future

Also available in: Atom PDF