Project

General

Profile

Actions

action #130889

closed

[qe-core] test fails in Sysctl - test returns other than expected values in single incidents (S:M:29299)

Added by vsvecova 10 months ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2023-06-14
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

Failures in the following:

https://openqa.suse.de/tests/11286164#step/Sysctl/469

# Test messages # Sysctl_net_ipv4_tcp_mem
# failure: 

expected: 21800:23000 29500:31000 44800:46000
returned: 22326 29769   44652
invalid value: '44652', expected '44800:46000'

https://openqa.suse.de/tests/11286164#step/Sysctl/803

 # Test messages # Sysctl_user_max_cgroup_namespaces
# failure: 

expected: 7740:7880
returned: 7706
invalid value: '7706', expected '7740:7880'

https://openqa.suse.de/tests/11286164#step/Sysctl/806

# Test messages # Sysctl_user_max_ipc_namespaces
# failure: 

expected: 7740:7880
returned: 7706
invalid value: '7706', expected '7740:7880'

https://openqa.suse.de/tests/11286164#step/Sysctl/807

 # Test messages # Sysctl_user_max_mnt_namespaces
# failure: 

expected: 7740:7880
returned: 7706
invalid value: '7706', expected '7740:7880'

https://openqa.suse.de/tests/11286164#step/Sysctl/808

# Test messages # Sysctl_user_max_net_namespaces
# failure: 

expected: 7740:7880
returned: 7706
invalid value: '7706', expected '7740:7880'

https://openqa.suse.de/tests/11286164#step/Sysctl/809

# Test messages # Sysctl_user_max_pid_namespaces
# failure: 

expected: 7740:7880
returned: 7706
invalid value: '7706', expected '7740:7880'

https://openqa.suse.de/tests/11286164#step/Sysctl/810

# Test messages # Sysctl_user_max_user_namespaces
# failure: 

expected: 7740:7880
returned: 7706
invalid value: '7706', expected '7740:7880'

https://openqa.suse.de/tests/11286164#step/Sysctl/811

# Test messages # Sysctl_user_max_uts_namespaces
# failure: 

expected: 7740:7880
returned: 7706
invalid value: '7706', expected '7740:7880'

https://openqa.suse.de/tests/11286164#step/Sysctl/850

# Test messages # Sysctl_vm_user_reserve_kbytes
# failure: 

expected: 61500:63000
returned: 61491
invalid value: '61491', expected '61500:63000'

openQA test in scenario sle-15-SP4-Server-DVD-Incidents-x86_64-mau-sles-sys-param-check@64bit-2gbram fails in
Sysctl

Test suite description

https://gitlab.suse.de/qa-css/sys-param-check

Reproducible

Fails since (at least) Build :29299:dtb-armv7l

Expected result

Last good: :29295:java-1_8_0-ibm (or more recent)

Further details

Always latest result in this scenario: latest

Actions #1

Updated by rfan1 10 months ago

I can see similar issue on sle15sp5 as well, and there are some bugs filed against the this issue before:

bsc#1183339#c11
bsc#1202375#c1

https://openqa.suse.de/tests/11350222/file/sys_param_check-sysctl.robot.html

TEST Sysctl_net_ipv4_udp_mem
Full Name:  Sysctl.Sysctl_net_ipv4_udp_mem
Documentation:  
Depends of the RAM resources bsc#1183339#c11 bsc#1202375#c1

Start / End / Elapsed:  20230614 19:58:36.436 / 20230614 19:58:36.438 / 00:00:00.002
Status: FAIL (critical)
Message:    expected: 44900:47000 59800:62000 89800:93000
returned: 44871 59828   89742
invalid value: '44871', expected '44900:47000'
invalid value: '89742', expected '89800:93000'
00:00:00.002KEYWORD LinuxLab_HRT_Lib . Sysctl Check Param Int net.ipv4.udp_mem, 44900:47000 59800:62000 89800:93000
Documentation:  
Check a sysctl parameter value(s) for a given integer value(s).

Start / End / Elapsed:  20230614 19:58:36.436 / 20230614 19:58:36.438 / 00:00:00.002
19:58:36.437    INFO    *INFO:* current value: 44871    59828   89742   
19:58:36.438    FAIL    expected: 44900:47000 59800:62000 89800:93000
returned: 44871 59828   89742
invalid value: '44871', expected '44900:47000'
invalid value: '89742', expected '89800:93000'
Actions #2

Updated by rfan1 10 months ago

Thanks to Jozef, https://bugzilla.suse.com/show_bug.cgi?id=1212403 was filed against to this issue.

Actions #3

Updated by dzedro 10 months ago

  • Status changed from New to Blocked
  • Assignee set to dzedro
Actions #4

Updated by maritawerner 10 months ago

  • Subject changed from test fails in Sysctl - test returns other than expected values in single incidents (S:M:29299) to [qe-core] test fails in Sysctl - test returns other than expected values in single incidents (S:M:29299)
Actions #5

Updated by dzedro 9 months ago

  • Status changed from Blocked to Resolved
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF