Project

General

Profile

Actions

action #128909

closed

Comments from investigation jobs contain warnings failing to parse SCC_ADDONS setting

Added by szarate 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2023-05-08
Due date:
2023-05-23
% Done:

0%

Estimated time:

Description

    lvm+resize_root:investigate:last_good_tests_and_build:52d5f6199bf6996bdb89f3404cf42cc856c8c046+186.1: Use of uninitialized value in split at /usr/share/openqa/script/../lib/OpenQA/Script/CloneJobSUSE.pm line 16. 1 job has been created:

This is specifically:

foreach my $SCC_ADDON (split(/,/, $settings->{'SCC_ADDONS'})) {

The affected test has a _XSCC_ADDONS setting but no SCC_ADDONS.

https://openqa.suse.de/tests/11052043#comments


Related issues 1 (0 open1 closed)

Related to openQA Project - action #128405: Missing investigate jobs on both o3+osd since months? size:MResolvedtinita2023-04-28

Actions
Actions #1

Updated by livdywan 11 months ago

  • Subject changed from Comments from investigation jobs have warnings that shouldn't be there to Comments from investigation jobs contain warnings failing to parse SCC_ADDONS setting
  • Description updated (diff)
Actions #2

Updated by tinita 11 months ago

  • Category set to Regressions/Crashes
  • Target version set to Ready
Actions #3

Updated by tinita 11 months ago

  • Status changed from New to In Progress
  • Assignee set to tinita
Actions #4

Updated by tinita 11 months ago

  • Status changed from In Progress to Feedback
Actions #5

Updated by tinita 11 months ago

  • Related to action #128405: Missing investigate jobs on both o3+osd since months? size:M added
Actions #6

Updated by tinita 11 months ago

I'm wondering why the Use of uninitialized value ended up in stdout, though. The openqa-investigate script only collects output from stdout for the comment content...

Actions #7

Updated by okurz 11 months ago

  • Priority changed from Normal to High
Actions #8

Updated by tinita 11 months ago

PR merged.
Also a more reliable solution which I did for #128405 :
https://github.com/os-autoinst/scripts/pull/231 Use openqa-clone-job --json-output

I could not find out why the warning ended up in the output because we don't redirect stderr to stdout.
Trying to reproduce it on the commandline behaves differently...

Actions #9

Updated by tinita 11 months ago

  • Status changed from Feedback to In Progress

To be clear about the problem:
If I call

out=$(openqa-clone-job --skip-chained-deps ...)

on the commandline, then a warning emitted from the clone script is printed in my terminal and does not end up in out.
The same call inside openqa-investigate, and the warning ends up in out. Which will now lead to errors from jq trying to parse JSON.

Actions #10

Updated by tinita 11 months ago

Another problem is that if I call openqa-clone-job with --json-output, it still outputs text intended to be read by humans, e.g.

May 08 15:23:49 ariel openqa-gru[10025]: jq (66 /opt/os-autoinst-scripts/openqa-investigate): parse error: Invalid numeric literal at line 1, column 8 (rc: 4 Input: >>>Cloning parents of opensuse-Tumbleweed-DVD-ppc64le-Build20230507-xfstests_nfs4.0-generic@ppc64le
May 08 15:23:49 ariel openqa-gru[10025]: {
May 08 15:23:49 ariel openqa-gru[10025]:    "3273075" : 3274318
May 08 15:23:49 ariel openqa-gru[10025]: }<<<)

:(
So maybe I should just delete everything until the first { or [.

Actions #11

Updated by openqa_review 11 months ago

  • Due date set to 2023-05-23

Setting due date based on mean cycle time of SUSE QE Tools

Actions #12

Updated by livdywan 11 months ago

szarate wrote:

This is specifically:

foreach my $SCC_ADDON (split(/,/, $settings->{'SCC_ADDONS'})) {

The affected test has a _XSCC_ADDONS setting but no SCC_ADDONS.

https://openqa.suse.de/tests/11052043#comments

As discussed in the Unblock I'll try to confirm what behavior we want here and propose a simple fix which should decouple this ticket from #128405

Another problem is that if I call openqa-clone-job with --json-output, it still outputs text intended to be read by humans, e.g.

which Tina will focus on wrt stderr/stdout handling.

Actions #13

Updated by livdywan 11 months ago

cdywan wrote:

szarate wrote:

This is specifically:

foreach my $SCC_ADDON (split(/,/, $settings->{'SCC_ADDONS'})) {

The affected test has a _XSCC_ADDONS setting but no SCC_ADDONS.

https://openqa.suse.de/tests/11052043#comments

As discussed in the Unblock I'll try to confirm what behavior we want here and propose a simple fix which should decouple this ticket from #128405

https://github.com/os-autoinst/openQA/pull/5127

Actions #14

Updated by okurz 11 months ago

PR from cdywan merged

Actions #15

Updated by livdywan 11 months ago

okurz wrote:

PR from cdywan merged

Ack. Next step before considering this "done" is stderr/stdout handling which Tina's working on i.e. making sure warnings don't leak into comments.

Actions #16

Updated by tinita 11 months ago

https://github.com/os-autoinst/scripts/pull/232 Capture and output stderr in runcli seperately

Actions #17

Updated by tinita 11 months ago

  • Status changed from In Progress to Feedback
Actions #18

Updated by tinita 11 months ago

  • Status changed from Feedback to Resolved

https://github.com/os-autoinst/scripts/pull/232 merged.

I can see stderr separately handled in the gru log now, and the investigation comments are appearing correctly now

Actions

Also available in: Atom PDF