Project

General

Profile

action #12830

opensuse-Tumbleweed-NET-x86_64-update_123@64bit fails to unlock screen probably because of wrong user

Added by okurz over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2016-07-23
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

observation

See in https://openqa.opensuse.org/tests/225309#step/consoletest_finish/9 that the screenlock does not disappear. In the video one can see that the password is typed but it fails with "Unlocking failed".

steps to reproduce

every time in this scenario, see https://openqa.opensuse.org/tests/227696?limit_previous=100#previous

  • clone_job.pl 227696

problem

The user is called "openQA", not bernhard, so I guess the password is different, too.

suggestion

update the hda image openSUSE-12.3-x86_64.hda and change username and password of "openQA" to bernhard with common password. An alternative would be to place special "update12.3" handling code in "check_screenlock".

dimstar: Assigning to you just for the decision, can reassign to anyone (me) to do it.


Related issues

Has duplicate openQA Tests - action #14036: openSUSE 12.3 disk image: invalid usernamesClosed2016-10-02

History

#1 Updated by dimstar over 6 years ago

  • Assignee changed from dimstar to okurz

I'd rather change the disk image than overcmoplicating the tests with such special cases...

#2 Updated by okurz over 6 years ago

  • Status changed from New to In Progress

I am trying to run this in a screen session on root@openqaworker1

rsync -aHP /var/lib/openqa/share/factory/hdd/openSUSE-12.3-x86_64.hda .

next planned steps

  • mount image
  • chroot into image installation as root
  • change user openQA to bernhard with updated password
  • unmount
  • copy back

#3 Updated by okurz over 6 years ago

worklog on openqaworker1

mkdir poo#12830_update_12.3_to_tw
cd poo#12830_update_12.3_to_tw
rsync -aHP /var/lib/openqa/share/factory/hdd/openSUSE-12.3-x86_64.hda .
modprobe nbd max_part=63
qemu-nbd -c /dev/nbd2 -P 2 openSUSE-12.3-x86_64.hda 
qemu-nbd -c /dev/nbd3 -P 3 openSUSE-12.3-x86_64.hda 
mkdir nbd0p{1,2,3}
mount /dev/nbd2 nbd0p2/
mount /dev/nbd3 nbd0p3/
cd nbd0p2/
vim etc/passwd
vim sysconfig/displaymanager 
passwd bernhard
cd ../nbd0p3/
mv bernhard/ bernhard.old
mv openqa/ bernhard
mv bernhard.old/ susetesting
cd ..
mount -o bind nbd0p3/ nbd0p2/home/
chroot nbd0p2/
umount nbd0p2/home/
umount nbd0p3/
umount nbd0p2/
/usr/bin/qemu-kvm -serial file:serial0 -soundhw ac97 -global isa-fdc.driveA= -vga cirrus -m 1024 -cpu qemu64 -netdev user,id=qanet0 -device virtio-net,netdev=qanet0,mac=52:54:00:12:34:56 -device virtio-scsi-pci,id=scsi0 -device virtio-blk,drive=hd1 -snapshot -drive file=openSUSE-12.3-x86_64.hda,cache=unsafe,if=none,id=hd1,format=qcow2 -drive media=cdrom,if=none,id=cd0,format=raw,file=/var/lib/openqa/share/factory/iso/openSUSE-Tumbleweed-NET-x86_64-Snapshot20160728-Media.iso -device scsi-cd,drive=cd0,bus=scsi0.0 -boot once=d,menu=on,splash-time=5000 -device usb-ehci -device usb-tablet -smp 1 -enable-kvm -no-shutdown -vnc :120,share=force-shared
qemu-nbd -d /dev/nbd3
qemu-nbd -d /dev/nbd2
qemu-nbd -d /dev/nbd1

On ariel renamed /var/lib/openqa/factory/hdd/openSUSE-12.3-x86_64.hda to openSUSE-12.3-x86_64.hda.bak_before_poo12830, copied back image from openqaworker1 to /var/lib/openqa/factory/hdd/openSUSE-12.3-x86_64.hda, retriggered test --> t#234315

#4 Updated by okurz over 6 years ago

cloned and ran as t#234316 but failed in
first_boot again, this time because autologin was not configured. I could rechange the image again or try with NOAUTOLOGIN=1.
-> t#234619

#5 Updated by okurz over 6 years ago

times out finding display manager in time, retrying with higher timeout using TIMEOUT_SCALE=4

-> t#234651

#6 Updated by okurz over 6 years ago

does not look like I actually improved the situation. For now I renamed images

mv openSUSE-12.3-x86_64.hda openSUSE-12.3-x86_64-GM-kde@64bit-poo12830_okurz.qcow2
mv openSUSE-12.3-x86_64.hda.bak_before_poo12830 openSUSE-12.3-x86_64.hda

I will take a look if I messed up the config with renaming the home dir and user.

#7 Updated by okurz over 6 years ago

mounted image again and replaced some occurences of 'openqa' to 'bernhard' in /home/bernhard.

Synced in one call with

okurz@ariel:~> sudo rsync -e 'sudo -u okurz ssh' -aHP root@openqaworker1:/home/okurz/poo#12830_update_12.3_to_tw/openSUSE-12.3-x86_64.hda  /var/lib/openqa/factory/hdd/openSUSE-12.3-x86_64-GM-kde@64bit-poo12830_okurz.qcow2

Triggered with

$ openqa_clone_job_o3 234651 HDD_1=openSUSE-12.3-x86_64-GM-kde@64bit-poo12830_okurz.qcow2
Created job #234916: opensuse-Tumbleweed-DVD-x86_64-Build20160728-update_123@64bit

-> t#234916

#8 Updated by okurz over 6 years ago

no, didn't help. I guess a cleaner approach is to reinstall openSUSE-12.3 for the image.

#9 Updated by okurz over 6 years ago

  • Assignee deleted (okurz)

#10 Updated by okurz over 6 years ago

  • Has duplicate action #14036: openSUSE 12.3 disk image: invalid usernames added

#11 Updated by dimstar about 6 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

I finished off this work today

  • Downloaded the openSUSE-12.3-x86_64.hda from openQA's fixed storage
  • Booted the disk in a local qemu, to runlevel 3
  • Identified that there were already two users configured (openqa & bernhard); likely I continued on the disk done by Oliver
  • Adjusted the password to both users to the default password used by openQA tests
  • Updated /etc/sysconfig/displaymanager to autologin as 'bernhard' (same we do in all other tests)
  • rebooted to runlevel 5 (local verification)
  • Shutdown the machine
  • copied the resulting .hda file back to openQA (backup has been preserved, just in case)

The first test run based on the new .hda looks much better and that specific issue has been solved. Reference test:
https://openqa.opensuse.org/tests/305103

There are now minor issues inside the product to take care off (seems some font settings are not correct for example - but that's something for the TW product to adjust)

Also available in: Atom PDF