Project

General

Profile

Actions

action #127412

closed

[openQA-in-openQA] test fails in test_distribution size:M

Added by tinita over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2023-04-10
Due date:
% Done:

0%

Estimated time:

Description

Observation

openQA test in scenario openqa-Tumbleweed-dev-x86_64-openqa_install+publish@64bit-2G fails in
test_distribution

Test suite description

Maintainer: okurz@suse.de Test for installation of openQA itself. To be used with "openqa" distri. Publishes an qcow2 image including the openQA installation ready to run as an appliance.

Reproducible

Fails since (at least) Build :TW.19791 (current job)

Expected result

Last good: :TW.19790 (or more recent)

Further details

Always latest result in this scenario: latest

I've seen this happening three times now.

fetchneedles is called, and during git clone os-autoinst-istri-opensuse it fails with fatal: fetch-pack: invalid index-pack output.

Suggestions

  • Maybe the curl command took a long time due to slowdowns on either GitHub or the o3 network
  • Consider changing the test inside the test to not use distri-opensuse but a different repo (to avoid the large clone) i.e. using -example instead
  • Re-try the fetchneedles command
  • Probably DON'T retry inside the fetchneedles command since that is typically run in a cron job
  • Confirm with Oli if anyone might be using the resulting qcow2 image including the needles

Files

fetchneedles-git-error.png (30.2 KB) fetchneedles-git-error.png Screenshot of git error tinita, 2023-06-02 21:24

Related issues 1 (0 open1 closed)

Copied to openQA Project - action #127622: [openQA-in-openQA] openqa_install+publish takes very long - Use example distribution instead of os-autoinst-distri-opensuse size:MResolvedosukup

Actions
Actions #1

Updated by okurz over 1 year ago

  • Category set to Regressions/Crashes
  • Priority changed from Normal to High
  • Target version set to Ready
Actions #2

Updated by livdywan over 1 year ago

  • Subject changed from [openQA-in-openQA] test fails in test_distribution to [openQA-in-openQA] test fails in test_distribution size:M
  • Description updated (diff)
  • Status changed from New to Workable
Actions #3

Updated by tinita over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to tinita
Actions #4

Updated by tinita over 1 year ago

  • Copied to action #127622: [openQA-in-openQA] openqa_install+publish takes very long - Use example distribution instead of os-autoinst-distri-opensuse size:M added
Actions #5

Updated by tinita over 1 year ago

This thread on Stackoverflow suggests that increasing the buffer size could also help, e.g.

git config --global http.postBuffer 524288000
git config --global http.maxRequestBuffer 524288000
git config --global core.compression 0

or

[core] 
packedGitLimit = 512m 
packedGitWindowSize = 512m 
[pack] 
deltaCacheSize = 2047m 
packSizeLimit = 2047m 
windowMemory = 2047m
Actions #6

Updated by tinita over 1 year ago

  • Status changed from In Progress to Feedback
Actions #7

Updated by tinita over 1 year ago

  • Status changed from Feedback to Resolved

PR merged and works. So far we haven't seen the error again.
Also there were many needles deleted yesterday, so the repo is smaller and it's less likely that we run into the problem.
If it still happened we will get notified.

Actions #8

Updated by tinita about 1 year ago

For the record, I attached a screenshot of the error, in case the test gets deleted at some point

Actions

Also available in: Atom PDF