Project

General

Profile

Actions

action #124484

closed

Flaky coverage in lib/openQA/Worker/Job.pm

Added by okurz over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2023-02-14
Due date:
% Done:

0%

Estimated time:

Description

Motivation

See https://github.com/os-autoinst/openQA/pull/4997#issuecomment-1428080611

Acceptance criteria

  • AC1: Test coverage in lib/openQA/Worker/Job.pm is not flaky anymore
Actions #1

Updated by kraih over 1 year ago

  • Assignee set to kraih
Actions #2

Updated by kraih over 1 year ago

  • Status changed from New to In Progress
Actions #3

Updated by openqa_review about 1 year ago

  • Due date set to 2023-03-07

Setting due date based on mean cycle time of SUSE QE Tools

Actions #4

Updated by kraih about 1 year ago

  • Description updated (diff)
Actions #5

Updated by kraih about 1 year ago

The flaky code block appears to be covered by this test block in t/33-developer_mode.t. One of the tests suggests that it is intended to be flaky:

    ok wait_for_result_panel($driver, qr/(State: cancelled|Result: (user_cancelled|passed))/),
      'test 1 has been cancelled (if it was fast enough to actually pass that is ok, too)';
Actions #6

Updated by kraih about 1 year ago

This is the commit that started allowing both user_cancelled and passed to be acceptable test results. It's an intentional race condition.

Actions #7

Updated by kraih about 1 year ago

PR marking the block in question as uncoverable: https://github.com/os-autoinst/openQA/pull/5023

Actions #8

Updated by kraih about 1 year ago

  • Status changed from In Progress to Feedback
Actions #9

Updated by kraih about 1 year ago

Merged.

Actions #10

Updated by okurz about 1 year ago

  • Due date deleted (2023-03-07)
  • Status changed from Feedback to Resolved

Resolved as the change is very specific and we trust it and if code coverage would still be flaky we would notice ourselves immediately.

Actions

Also available in: Atom PDF