Project

General

Profile

action #121441

logreport o3: Can't call method "results" on an undefined value at /.../OpenQA/WebAPI/Controller/Test.pm line 735

Added by tinita about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2022-12-05
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

On o3 we saw the following error message a couple of times today:

[2022-12-05T10:44:40.964209Z] [error] [uhBoyP7XhrnP] Can't call method "results" on an undefined value at
/usr/share/openqa/script/../lib/OpenQA/WebAPI/Controller/Test.pm line 735.
[2022-12-05T10:46:25.183170Z] [error] [ukRiUmIjE_ZB] Can't call method "results" on an undefined value at
/usr/share/openqa/script/../lib/OpenQA/WebAPI/Controller/Test.pm line 735.
[2022-12-05T10:46:37.239147Z] [error] [siPb5MyR3vW_] Can't call method "results" on an undefined value at
/usr/share/openqa/script/../lib/OpenQA/WebAPI/Controller/Test.pm line 735.
[2022-12-05T10:47:02.702829Z] [error] [Iz4unNwdyEWX] Can't call method "results" on an undefined value at
/usr/share/openqa/script/../lib/OpenQA/WebAPI/Controller/Test.pm line 735.

Reproduced it with https://openqa.opensuse.org/tests/1381836/modules/check_default_network_manager/fails which returns with a 500 server error


Related issues

Related to openQA Project - action #121444: logreport o3: Can't open file ".../details-gd.json": No such file or directory at OpenQA/Schema/Result/JobModules.pm line 95 size:MResolved2022-12-052022-12-20

History

#1 Updated by tinita about 2 months ago

  • Description updated (diff)

#2 Updated by tinita about 2 months ago

  • Description updated (diff)

#3 Updated by tinita about 2 months ago

  • Description updated (diff)

#4 Updated by dheidler about 2 months ago

  • Assignee set to dheidler

#5 Updated by dheidler about 2 months ago

  • Status changed from New to Feedback

#6 Updated by dheidler about 2 months ago

  • Related to action #121444: logreport o3: Can't open file ".../details-gd.json": No such file or directory at OpenQA/Schema/Result/JobModules.pm line 95 size:M added

#7 Updated by mkittler about 2 months ago

  • Status changed from Feedback to Resolved

Looks like it works in production.

Also available in: Atom PDF