Project

General

Profile

action #120426

[qe-core][functional][sle15sp5] Merge 'extra_tests_webserver' and 'extra_tests_webframeworks' due to duplicate test modules

Added by rfan1 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
Start date:
2022-11-15
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Description

https://openqa.suse.de/tests/9919496
https://openqa.suse.de/tests/9920105

Currently, the test 'extra_tests_webserver' and 'extra_tests_webframeworks' have duplicate test modules 'flask' and 'django'. so plan
to merge them into one job

Plan

Remove 'extra_tests_webframeworks' and alter 'extra_tests_webserver' with zypper_log_packages.

History

#1 Updated by rfan1 2 months ago

  • Description updated (diff)

#3 Updated by vsvecova 2 months ago

Doesn't look like it's working in QAM jobs: https://openqa.suse.de/tests/9974382

It dies and incompletes on SLE15-GA up until SLE15-SP3 (it is not scheduled on SP4).

Reason: tests died: unable to load main.pm, check the log for the cause (e.g. syntax error)

#4 Updated by szarate 2 months ago

Richard, the schedule is pointing to the old one, YAML_SCHEDULE=schedule/functional/extra_tests_webframeworks.yaml instead of the one from maintenance

#5 Updated by pdostal 2 months ago

This is expected as the extra_tests_webframeworks has been removed today but the YAML removed yesterday and the test scheduled between.

#6 Updated by vsvecova 2 months ago

I'm going to force-mark the incomplete jobs as softfailed then - apparently the module isn't supposed to be there anymore, so there's no risk in doing that, I gather.

#8 Updated by rfan1 2 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF