Project

General

Profile

action #119245

openQA in openQA test fails in docker build

Added by jbaier_cz 4 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2022-10-24
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario openqa-Tumbleweed-dev-x86_64-openqa_from_containers@64bit-2G fails in
build

The docker build fails during zypper ref with "Update repository of openSUSE Backports is invalid" error (can be seen on video on mark 0:44, 0:52 and 0:57 -- so the retry works but does not help).

Test suite description

Maintainer: okurz@suse.de Test for running openQA itself from containers. To be used with "openqa" distri. Introduced retry on the job level due to https://progress.opensuse.org/issues/108665 as there can still be sporadic network issues sometimes.

Reproducible

Fails since (at least) Build :TW.12513 (current job)

Expected result

Last good: :TW.12512 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #123106: [tools][openQA-in-openQA][sporadic] test fails in docker build size:MResolved2023-01-13

History

#1 Updated by okurz 4 months ago

  • Tags set to reactive work
  • Priority changed from Normal to Urgent

#2 Updated by mkittler 4 months ago

  • Assignee set to mkittler

Recent tests pass again so despite the retry not helping it looks like a sporadic issue. Likely a longer waiting time between the retries would help.

#3 Updated by mkittler 4 months ago

  • Status changed from New to Feedback

The time between attempts is already 30 seconds so for now I'd just enable exponential back-off: https://github.com/os-autoinst/os-autoinst-distri-openQA/pull/103

#4 Updated by okurz 4 months ago

  • Status changed from Feedback to Resolved

merged. We will be notified in case this fails again.

#5 Updated by jbaier_cz 26 days ago

  • Related to action #123106: [tools][openQA-in-openQA][sporadic] test fails in docker build size:M added

Also available in: Atom PDF