Project

General

Profile

action #11920

autoyast reboot can interfere with grub timeout

Added by okurz about 6 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2016-05-11
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

observation

https://openqa.suse.de/tests/384439/modules/grub_test/steps/1 fails, last good https://openqa.suse.de/tests/384158/modules/grub_test/steps/1

steps to reproduce

rerun "autoupgrade_sle12_sp1@64bit"

problem

looking at the logfile reveals:

17:59:57.3016 MATCH(autoyast-boot-grub2-20150923:1.00)
17:59:57.3120 MATCH(autoyast-boot-pxe-20150714:0.00)
17:59:57.4166 >>> assert_screen: found autoyast-boot-grub2-20150923, similarity 0.99 @ 138/64
18:00:01.3442 ||| finished autoyast_reboot autoyast at 2016-05-10 18:00:01 (14 s)
18:00:06.8040 ||| starting grub_test tests/installation/grub_test.pm at 2016-05-10 18:00:06
18:00:06.8047 Debug: /var/lib/openqa/share/tests/sle/tests/installation/grub_test.pm:17 called testapi::assert_screen
18:00:06.8049 <<< assert_screen(mustmatch='grub2', timeout=30)
…
18:00:38.2395 >>> assert_screen: match=grub2 timed out after 30

which leads to
H1. loading the next test takes too long to be working during the grub timeout so looking for the bootmenu already in the autoyast/autoyast_reboot.pm causes this error

suggestion

  • Don't wait for grub menu already in the autoyast/autoyast_reboot.pm
  • Find the cause for loading a test to take more than 5 seconds

History

#1 Updated by okurz about 6 years ago

psladek was the developer of the autoyast test so he might be able to help

#2 Updated by okurz almost 6 years ago

  • Assignee set to psladek

please take a look

#3 Updated by maritawerner over 5 years ago

Pavel, any update here? Are you aware of that ticket?

#4 Updated by psladek over 5 years ago

Sorry, it somehow slipped out of my mind when I started to work on SLEPOS tests,
will look into this when time permits (in a week or two, if needed faster, please adjust the priority)

#5 Updated by okurz over 5 years ago

  • Status changed from New to Rejected

So we meet again :-) the job url is now not accessible anymore and time has moved on …

Also available in: Atom PDF