Project

General

Profile

action #116860

[qe-core] test fails in systemtap - Installed kernel-devel does not match kernel version

Added by vsvecova 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2022-09-20
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Expected: 4.12.14-122.130, Found: Other kernel-default-devel versions

openQA test in scenario sle-12-SP5-Server-DVD-Incidents-x86_64-mau-extratests2@64bit fails in
systemtap

Similar issue happening on SLE15: https://openqa.suse.de/tests/9547217#step/systemtap/59

The issue is not happening consistently - on SLE15, it is only in the :25953:flatpak incident (other incident runs are fine), while on 12-SP5 it is currently only on :25853:sqlite3 and :PTF:24862:wicked, while other incident runs are green.

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. Run console tests against aggregated test repo

Reproducible

Fails since (at least) Build :25853:sqlite3 (current job)

Expected result

Last good: :25980:sudo (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by maritawerner 2 months ago

  • Subject changed from test fails in systemtap - Installed kernel-devel does not match kernel version to [qe-core] test fails in systemtap - Installed kernel-devel does not match kernel version

#2 Updated by VANASTASIADIS 2 months ago

Looking at all subsequent tests that pass, I see that they have kernel version 4.12.14-122.133-default (which is matching the available -devel package). i.e. https://openqa.suse.de/tests/9549382/logfile?filename=serial_terminal.txt

The failing ones have the previous version (4.12.14-122.130-default). i.e. https://openqa.suse.de/tests/9541892/logfile?filename=serial_terminal.txt

I would say it's probably an image issue and not a test or specific update issue

#3 Updated by VANASTASIADIS 2 months ago

  • Assignee set to VANASTASIADIS

#4 Updated by VANASTASIADIS 2 months ago

Latest test for the same update that failed in 15 passed: kernel-default is now bumped to latest version:
https://openqa.suse.de/tests/9555696

Same thing for 12: https://openqa.suse.de/tests/9555674

Should we close this issue? It rarely happens when there's a version bump that kernel-default and kernel-default-devel mismatch (usually available devel version in the repos is the latest, but image has the previous default version).

#5 Updated by VANASTASIADIS 2 months ago

as agreed on qe-core, I will append to the output that it's probably good to wait for the next runs and see if the kernel version is updated and the test passes, as is the case usually

#6 Updated by VANASTASIADIS 2 months ago

  • Status changed from New to In Progress
  • Target version set to QE-Core: Ready

#7 Updated by VANASTASIADIS about 2 months ago

  • Status changed from In Progress to Resolved

pr merged, resolving the issue.

Also available in: Atom PDF