Project

General

Profile

action #116614

openqa-label-known-issues might label jobs incorrectly

Added by mkittler 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2022-09-15
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

E.g. the predecessor of https://openqa.suse.de/tests/9507638#comment-611620 was maybe labeled incorrectly as its logs are very unlikely matching the regex of #114523. Unfortunately the predecessor is gone so it is hard to tell whether openqa-label-known-issues is really at fault here.

This looks bad enough so we should likely investigate further whether there are more examples.


Note that the regex of the wrongly assigned ticket #114523 is at the time the problematic jobs were discovered (?s)aarch64.*uefi.*no candidate needle.*grub. That is definitely not strict enough, e.g. it lead to https://openqa.opensuse.org/tests/2593426 being labeled (and then the label was even carried over). In this case openqa-label-known-issues was not at fault; the log really matched that regex (if . is allowed to match newline characters).

History

#1 Updated by ggardet_arm 3 months ago

I have seen it on o3 as well, but I did not investigate it yet.

#2 Updated by ggardet_arm 3 months ago

#3 Updated by mkittler 3 months ago

Looks like https://openqa.opensuse.org/tests/2666511 is only labeled because the regex is not strict enough (so not a bug in openqa-label-known-issues).

#4 Updated by okurz 3 months ago

  • Category set to Concrete Bugs
  • Priority changed from Normal to High
  • Target version set to Ready

#5 Updated by tinita 3 months ago

  • Status changed from New to In Progress
  • Assignee set to tinita

#6 Updated by tinita 3 months ago

  • Status changed from In Progress to Feedback

I changed the title of #114523 assuming that no candidate needle[^\n]*grub should be matched on the same line.
Worked for me as expected on an example logfile.

#7 Updated by tinita 2 months ago

  • Status changed from Feedback to In Progress

#8 Updated by tinita 2 months ago

okurz can you give me the autoinst-log.txt of the original job you created the regex from?
Like I said in the meeting, it's hard to guess if it's matching correctly if I don't know what it should match.

#9 Updated by okurz 2 months ago

  • Status changed from In Progress to Resolved

tinita wrote:

okurz can you give me the autoinst-log.txt of the original job you created the regex from?

sorry, I don't have that available anymore. If we can't find a good way to reproduce let's leave it as is.

Also available in: Atom PDF