Project

General

Profile

action #116051

[qe-core] Missing update debug repositories for 12-SP3-LTSS-TERADATA

Added by pcervinka 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-Updates-x86_64-mau-extratests-kdump@64bit fails in
kdump_and_crash

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. Run console tests against aggregated test repo

Reproducible

Fails since (at least) Build 20220829-1

Expected result

Last good: 20220825-1 (or more recent)

Further details

Always latest result in this scenario: latest

Test fail in preparation phase, when it tries to install kernel-default-debuginfo:

2022-08-30 05:34:49 <2> susetest(2461) [zypper:req] SolverRequester.cc(install):309 kernel-default-debuginfo-4.4.180-94.171.1 cap:kernel-default-debuginfo == 4.4.180-94.171.1 (mod) not found
2022-08-30 05:34:49 <5> susetest(2461) [zypp] Exception.cc(log):166 Zypper.cc(doCommand):4340 THROW:    name or capability not found

Package is not available, because debug repositories are not present on prepared SUT.

There is only:

1 | 12-SP3-LTSS-TERADATA-Updates                                                                       | 12-SP3-LTSS-TERADATA-Updates                          | Yes     | (r ) Yes  | Yes     | http://dist.suse.de/ibs/SUSE/Updates/SLE-SERVER/12-SP3-LTSS-TERADATA/x86_64/update/

There should be http://dist.suse.de/ibs/SUSE/Updates/SLE-SERVER/12-SP3-LTSS-TERADATA/x86_64/update_debug

There should be also debug repositories for maintenance updates.

For example, incident 25601 has update repo:
http://download.suse.de/ibs/SUSE:/Maintenance:/25601/SUSE_Updates_SLE-SERVER_12-SP3-LTSS-TERADATA_x86_64/

But there should be also:
https://download.suse.de/ibs/SUSE:/Maintenance:/25601/SUSE_Updates_SLE-SERVER_12-SP3-TERADATA_x86_64_debug/

Expected result

  • 12-SP3-LTSS-TERADATA Debug repositories are included in mru-install-minimal-with-addons.
  • 12-SP3-LTSS-TERADATA Debug repositories for incidents are included in mru-install-minimal-with-addons.

History

#1 Updated by mgrifalconi 3 months ago

  • Assignee set to mgrifalconi

seems like you found the solution for https://progress.opensuse.org/issues/115994
Will try to add the missing repo!
EDIT:
I see dvenkatachala picked that ticket, I will let her know :)

#2 Updated by maritawerner 3 months ago

  • Subject changed from Missing update debug repositories for 12-SP3-LTSS-TERADATA to [qe-core] Missing update debug repositories for 12-SP3-LTSS-TERADATA

#3 Updated by mgrifalconi 3 months ago

  • Status changed from New to Resolved
  • Start date deleted (2022-08-31)
  • % Done changed from 0 to 100

Solved by the PR on the other progress issue linked in the previous comment

Also available in: Atom PDF