Project

General

Profile

action #114688

[qe-core][qem] test fails in hostname_inst

Added by vsvecova 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2022-07-26
Due date:
% Done:

100%

Estimated time:
4.00 h
Difficulty:

Description

Observation

During the installation, the test goes back to partitioning instead of user creation, even though the partitioning part was already finished two modules earlier.

openQA test in scenario sle-15-SP1-Server-DVD-Incidents-x86_64-mru-install-minimal-with-addons@64bit fails in
hostname_inst

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml.

Reproducible

Fails since (at least) Build :24850:ant

Expected result

Last good: :24986:openldap2 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #115079: [qe-core][qem&functional] Many test failures due to low performance on arm workersNew2022-08-08

History

#1 Updated by szarate 2 months ago

  • Tags set to bugbusters
  • Priority changed from Normal to High
  • Target version set to QE-Core: Ready

#2 Updated by rfan1 2 months ago

Let me try QEMURAM=4096

# openqa-clone-job  --from http://openqa.suse.de --host http://openqa.suse.de 9208154  _GROUP_ID=0 -skip-download --skip-chained-deps BUILD=114688 QEMURAM=4096
Created job #9215577: sle-15-SP1-Server-DVD-Incidents-x86_64-Build:25166:java-11-openjdk-mru-install-minimal-with-addons@64bit -> http://openqa.suse.de/t9215577

#3 Updated by rfan1 2 months ago

  • Status changed from New to In Progress
  • Assignee set to rfan1
  • % Done changed from 0 to 20
  • Estimated time set to 4.00 h

QEMURAM=4096 can help, let me try to use 2048 and do more tests to see [then we don't need to occupy much resource]

#4 Updated by rfan1 2 months ago

  • % Done changed from 20 to 50

2048 works fine as well, let me revise the code:

#for i in 1 2 3; do openqa-clone-job  --from http://openqa.suse.de --host http://openqa.suse.de 9208154  _GROUP_ID=0 -skip-download --skip-chained-deps BUILD=114688_2G QEMURAM=2048 PUBLISH_HDD_1='' PUBLISH_PFLASH_VARS='';sleep 1;done
Created job #9220889: sle-15-SP1-Server-DVD-Incidents-x86_64-Build:25166:java-11-openjdk-mru-install-minimal-with-addons@64bit -> http://openqa.suse.de/t9220889
Created job #9220899: sle-15-SP1-Server-DVD-Incidents-x86_64-Build:25166:java-11-openjdk-mru-install-minimal-with-addons@64bit -> http://openqa.suse.de/t9220899
Created job #9220902: sle-15-SP1-Server-DVD-Incidents-x86_64-Build:25166:java-11-openjdk-mru-install-minimal-with-addons@64bit -> http://openqa.suse.de/t9220902

#5 Updated by rfan1 2 months ago

  • Tags changed from bugbusters to bugbusters, qe-core-coverage
  • % Done changed from 50 to 80

#6 Updated by rfan1 2 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 80 to 90

#7 Updated by vsvecova 2 months ago

#8 Updated by rfan1 2 months ago

vsvecova wrote:

I'm actually still seeing the same: https://openqa.suse.de/tests/9236019#step/hostname_inst/2

https://gitlab.suse.de/qa-maintenance/qam-openqa-yml/-/merge_requests/338

It is not merged yet... let me ask for someone who has merge permission to review and merge it asap.

#9 Updated by rfan1 2 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 90 to 100

All cases are green from 19hours ago:
https://openqa.suse.de/tests/9236019#next_previous

#10 Updated by szarate 2 months ago

  • Sprint set to QE-Core: July Sprint (Jul 06 - Aug 03)

#11 Updated by dzedro 2 months ago

I reverted the PR because it's affecting all SLE12 and breaking sysctl test, because with 2048 RAM kdump is enabled
Before: https://openqa.suse.de/tests/9243670#step/installation_overview/2
Now: https://openqa.suse.de/tests/9251677#step/installation_overview/2

Instead added QEMURAM=2048 on all 15+ Server-DVD-Incidents in Medium Types

#12 Updated by rfan1 2 months ago

dzedro wrote:

I reverted the PR because it's affecting all SLE12 and breaking sysctl test, because with 2048 RAM kdump is enabled
Before: https://openqa.suse.de/tests/9243670#step/installation_overview/2
Now: https://openqa.suse.de/tests/9251677#step/installation_overview/2

Instead added QEMURAM=2048 on all 15+ Server-DVD-Incidents in Medium Types

dzedro,
Thanks, I will pay more attention on the changes which may have side effect there.

#13 Updated by rfan1 about 2 months ago

  • Related to action #115079: [qe-core][qem&functional] Many test failures due to low performance on arm workers added

Also available in: Atom PDF