Project

General

Profile

Actions

action #113141

closed

[sporadic] OBS checks fail os-autoinst test "Calling 'isotovideo --help' returns exit code 0" from t/44-scripts.t but only on aarch64?

Added by okurz over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2022-07-01
Due date:
% Done:

0%

Estimated time:

Description

Observation

From https://build.opensuse.org/package/live_build_log/devel:openQA/os-autoinst/openSUSE_Tumbleweed/aarch64

[  985s] 3: 
[  985s] 3: #   Failed test 'Calling 'isotovideo --help' returns exit code 0'
[  985s] 3: #   at t/44-scripts.t line 29.
[  985s] 3: #          got: '31744'
[  985s] 3: #     expected: '0'
[  985s] 3: # Output: 
[  987s] 3: # Looks like you failed 1 test of 6.
[  987s] 3: [12:48:35] t/44-scripts.t ........................... 
[  987s] 3: ok 1 - Calling 'check_needles.pl --help' returns exit code 0
[  987s] 3: ok 2 - Calling 'check_qemu_oom --help' returns exit code 0
[  987s] 3: ok 3 - Calling 'imgsearch --help' returns exit code 0
[  987s] 3: not ok 4 - Calling 'isotovideo --help' returns exit code 0
[  987s] 3: ok 5 - Calling 'os-autoinst-openvswitch --help' returns exit code 0
[  987s] 3: ok 6 - no (unexpected) warnings (via done_testing)
[  987s] 3: 1..6
[  987s] 3: Dubious, test returned 1 (wstat 256, 0x100)
[  987s] 3: Failed 1/6 subtests 

Seems to happen a lot lately but only on aarch64 and apparently not all the time, currently green at time of writing.
Exit code 31744 >> 8 = 124, meaning "command terminated by SIGTERM". Maybe a race condition due to multiple background processes – which we shouldn't even spawn when we just want to call "--help" – which only really shows up on aarch64 as it's slower.

Suggestions

  • For now exclude the test from OBS checks on aarch64
  • Check the "--help" route, and see what else might be running in the background
  • Fix the problem

Rollback steps

  • Enable test on OBS checks again

Related issues 1 (0 open1 closed)

Copied to openQA Project - action #113348: [timeboxed:2h] OBS checks fail os-autoinst test "Calling 'isotovideo --help' returns exit code 0" from t/44-scripts.t but only on aarch64? -- initial investigation of "--help" route size:SResolvedtinita2022-07-01

Actions
Actions

Also available in: Atom PDF