Project

General

Profile

action #112679

[qe-core]test fails in qaset_pre_patch_run

Added by apappas 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2022-06-17
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

qaset_pre_patch_run
fails with

# wait_serial expected: "echo 'SQ_TEST_RUN_LIST=(\n\t_reboot_off\n\tbash\n)' > /root/qaset/config; echo bBdB5-\$?-"
# Result:
echo 'SQ_TEST_RUN_LIST=(
> _reboot_off
> bash
> )' > /root/qaset/config; echo bBdB5-$?-

This looks like a problem with the way the test handles newlines. In L55 we have:

     my $testsuites = "\n\t" . join("\n\t", @list) . "\n";

which might not be working.

Acceptance Criteria

  • AC1: Make sure newlines are handled correctly
  • AC2: Report any findings/conclusions to the qarun ticket and to the channel

Reproducible

Fails since (at least) Build 20220614-1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by punkioudi 2 months ago

  • Status changed from New to In Progress
  • Assignee set to punkioudi

#2 Updated by mloviska 2 months ago

Aren't trailing \ missing here as it tries to put a multiline command in bash ? :D

#3 Updated by mloviska 2 months ago

or it should be like, funny error :)

echo 'SQ_TEST_RUN_LIST=(\n\tt_reboot_off\n\tbash\n)'
SQ_TEST_RUN_LIST=(
        t_reboot_off
        bash
)

#4 Updated by punkioudi 2 months ago

I am not sure if this is causing the real issue, or this /usr/bin/env: ‘python’: No such file or directory :P
In 15-SP3 at least it works fine: https://openqa.suse.de/tests/8969696

In any case, I will unschedule the test for now and add a new progress ticket to get rid of the qa_run.

#6 Updated by punkioudi about 2 months ago

  • Priority changed from Immediate to Normal

Test has been removed, I reduced the prio, as another ticket has to be added by me to refactor this test case and remove qa_run.

#7 Updated by punkioudi about 1 month ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF