Project

General

Profile

Actions

action #111881

closed

coordination #111860: [epic] Upgrade all our infrastructure, e.g. o3+osd workers+webui and production workloads, to openSUSE Leap 15.4

Upgrade CI container image versions to Leap 15.4 size:M

Added by okurz almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Organisational
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Motivation

We should run a supported version of Leap.

Acceptance criteria

  • AC1: Ensure all CI container images we use are on Leap 15.4

Suggestions


Related issues 3 (0 open3 closed)

Related to openQA Project - action #113549: perl-Inline-Python will break on TW 0713+ size:MResolvedokurz2022-07-13

Actions
Copied from openQA Infrastructure - action #99240: Upgrade CI container image versions to Leap 15.3 size:MResolvedmkittler2021-09-24

Actions
Copied to openQA Project - action #130597: Upgrade CI container image versions to Leap 15.5Resolvedokurz

Actions
Actions #1

Updated by okurz almost 2 years ago

  • Copied from action #99240: Upgrade CI container image versions to Leap 15.3 size:M added
Actions #2

Updated by okurz almost 2 years ago

  • Subject changed from Upgrade CI container image versions to Leap 15.3 size:M to Upgrade CI container image versions to Leap 15.4
  • Description updated (diff)
  • Assignee deleted (mkittler)
  • Target version changed from Ready to future
  • Start date deleted (2021-09-24)
Actions #3

Updated by okurz almost 2 years ago

  • Category set to Organisational
Actions #4

Updated by okurz almost 2 years ago

  • Target version changed from future to Ready
Actions #5

Updated by livdywan almost 2 years ago

  • Subject changed from Upgrade CI container image versions to Leap 15.4 to Upgrade CI container image versions to Leap 15.4 size:M
  • Description updated (diff)
  • Status changed from New to Workable
Actions #6

Updated by okurz almost 2 years ago

  • Description updated (diff)
Actions #7

Updated by okurz almost 2 years ago

  • Description updated (diff)
  • Status changed from Workable to In Progress
  • Assignee set to okurz
Actions #8

Updated by openqa_review almost 2 years ago

  • Due date set to 2022-07-27

Setting due date based on mean cycle time of SUSE QE Tools

Actions #9

Updated by livdywan almost 2 years ago

We talked about it in the Unblock. We seem mostly in favor of using Tumbleweed again. And a suggestion was made that we can check the glibc version, so that the container build will fail if it changes and we can make sure it still works/ when to upgrade once that happens.

Actions #11

Updated by okurz almost 2 years ago

  • Description updated (diff)
Actions #13

Updated by okurz almost 2 years ago

https://build.opensuse.org/package/live_build_log/devel:openQA/os-autoinst_dev/containers-tw/x86_64 shows

[   15s] Can't locate builtin.pm in @INC (you may need to install the builtin module) (@INC contains: /.build /usr/lib/perl5/site_perl/5.36.0/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.36.0 /usr/lib/perl5/vendor_perl/5.36.0/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.36.0 /usr/lib/perl5/5.36.0/x86_64-linux-thread-multi /usr/lib/perl5/5.36.0 /usr/lib/perl5/site_perl) at /usr/lib/perl5/5.36.0/File/Copy.pm line 14.
[   15s] BEGIN failed--compilation aborted at /usr/lib/perl5/5.36.0/File/Copy.pm line 14.
[   15s] Compilation failed in require at /.build/runservices line 29.
[   15s] BEGIN failed--compilation aborted at /.build/runservices line 29.

no clue about that currently

Actions #14

Updated by okurz almost 2 years ago

  • Description updated (diff)

The above problem was in the build service. With the help from "Nei" in irc://chat.libera.chat/opensuse-factory we found a workaround and https://build.opensuse.org/request/show/989358 was created. I found and fixed some more problems and warnings, had them all fixed and now https://github.com/os-autoinst/os-autoinst/pull/2124 is merged.

Actions #15

Updated by okurz almost 2 years ago

  • Description updated (diff)
  • Status changed from In Progress to Feedback
Actions #16

Updated by okurz almost 2 years ago

  • Status changed from Feedback to Resolved

https://github.com/os-autoinst/openQA/pull/4748 merged. All parts considered done

Actions #17

Updated by okurz almost 2 years ago

  • Related to action #113549: perl-Inline-Python will break on TW 0713+ size:M added
Actions #18

Updated by okurz almost 2 years ago

  • Description updated (diff)
Actions #19

Updated by okurz almost 2 years ago

  • Status changed from Resolved to Feedback

https://build.opensuse.org/package/live_build_log/devel:openQA:ci/base/containers15.4/x86_64 now fails with

[   60s] Problem: the to be installed opencv3-devel-3.4.16-150400.1.9.x86_64 requires 'libopencv3_4 = 3.4.16', but this requirement cannot be provided
[   60s]   not installable providers: libopencv3_4-3.4.16-150400.1.9.x86_64[obs_repository]
[   60s]  Solution 1: deinstallation of patterns-base-fips-20200505-lp154.5.2.x86_64
[   60s]  Solution 2: do not ask to install a solvable providing pkgconfig(opencv)
[   60s]  Solution 3: break opencv3-devel-3.4.16-150400.1.9.x86_64 by ignoring some of its dependencies
[   60s] 

https://github.com/os-autoinst/openQA/pull/4758

merged. Now

In https://build.opensuse.org/package/live_build_log/devel:openQA:ci/base/containers/x86_64 I see

the to be installed opencv-devel-4.5.5-150400.1.28.x86_64 requires 'libopencv_videoio405 = 4.5.5', but this requirement cannot be provided
[  137s]   not installable providers: libopencv_videoio405-4.5.5-150400.1.28.x86_64[obs_repository]
[  137s]  Solution 1: deinstallation of patterns-base-fips-20200505-lp154.5.2.x86_64

which I can't reproduce locally when just using e.g. with podman build ... . Is there some special OBS repo added to build containers here? Something to add in the project config to resolve? Asked in https://matrix.to/#/!FlfFztBGbhgNNtDbhN:libera.chat/$aQUbMQ9X0xe7yG5ViurkujwtzUI4lnTo-AVpBG_kYc0

Actions #20

Updated by okurz almost 2 years ago

  • Due date deleted (2022-07-27)
  • Status changed from Feedback to Resolved

Solution was provided by fvogt in https://matrix.to/#/!FlfFztBGbhgNNtDbhN:libera.chat/$xskCsQDgq03b3e0HhmjpdfKd9Oa0l_EB95fdPGbGAXY and following:

Sounds like the prjconf is missing the workaround for a long standing OBS bug
Actually, you explicitly removed the workaround in your prjconf from devel:openQA:ci
You write !patterns-base-fips, but the ! is wrong, remove it
can you explain the error messages to us and how the prjconf chance fixes it?
https://github.com/openSUSE/obs-build/issues/487

Fixed it with the according change in https://build.opensuse.org/projects/devel:openQA:ci/prjconf, then https://build.opensuse.org/package/show/devel:openQA:ci/base rebuilt on top of Leap 15.4 and os-autoinst based on Tumbleweed. Then I retriggered a circleCI job dependencies-pr which updated https://github.com/os-autoinst/openQA/pull/4757

Actions #21

Updated by okurz 12 months ago

  • Copied to action #130597: Upgrade CI container image versions to Leap 15.5 added
Actions

Also available in: Atom PDF