Project

General

Profile

action #103617

Cover unhandled output in openQA "t" tests size:M

Added by okurz about 2 months ago. Updated 16 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2021-12-07
Due date:
2022-01-26
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

Observation

At the time of writing openQA "t" tests have some "unhandled test output":

[11:45:14] t/23-amqp.t ............................................... 3/? [2021-12-07 11:45:21.67648] [459] [debug] [pid:459] Sending AMQP event: some.topic
[2021-12-07 11:45:21.67689] [459] [debug] [pid:459] AMQP URL: amqp://guest:guest@localhost:5672/?exchange=pubsub&cacertfile=%2Fsome%2Fcacert.pem&certfile=%2Fsome%2Fcert.pem&keyfile=%2Fsome%2Fkey.pem
[11:45:14] t/23-amqp.t ............................................... ok    12621 ms ( 0.02 usr  0.00 sys + 11.91 cusr  0.44 csys = 12.37 CPU)
…
[11:45:39] t/24-worker-jobs.t ........................................ 20/? [WARN] Job 1 stopped because it exceeded MAX_JOB_TIME
[WARN] Found poolCKgM/base_state.json but failed to parse the JSON: 'false' expected, at character offset 0 (before "foo boo") at /usr/lib/perl5/vendor_perl/5.26.1/Mojo/JSON.pm line 31.

[11:45:39] t/24-worker-jobs.t ........................................ ok    11737 ms ( 0.08 usr  0.01 sys + 11.24 cusr  0.47 csys = 11.80 CPU)
[11:45:50] t/24-worker-overall.t ..................................... The signatures feature is experimental at t/24-worker-overall.t line 739.
[11:45:50] t/24-worker-overall.t ..................................... ok     4910 ms ( 0.05
…
[11:49:49] t/35-script_clone_job.t ................................... The signatures feature is experimental at t/35-script_clone_job.t line 31.
[11:49:49] t/35-script_clone_job.t ................................... ok     2555 ms ( 0.02 usr  0.00 sys +  2.34 cusr  0.17 csys =  2.53 CPU)

Acceptance criteria

  • AC1: No unhandled output from succeeding tests present

Suggestions

  • Reproduce individual test outputs locally, cover expected strings with Test::Output as we do in many other test modules
  • Add opt-in variable to make tests fail on unexpected output
  • Use Test::Warnings

History

#1 Updated by okurz about 2 months ago

  • Tags set to easy, starter, beginner, openQA, Test::Output, test output, tests, CI

#2 Updated by cdywan about 2 months ago

  • Subject changed from Cover unhandled output in openQA "t" tests to Cover unhandled output in openQA "t" tests size:M
  • Description updated (diff)
  • Status changed from New to Workable

#3 Updated by okurz about 2 months ago

  • Tags changed from easy, starter, beginner, openQA, Test::Output, test output, tests, CI to easy
  • Category changed from Concrete Bugs to Feature requests
  • Status changed from Workable to Feedback
  • Assignee set to okurz

https://github.com/os-autoinst/openQA/pull/4391 to cover t/24-worker-jobs.t and t/35-script_clone_job.t

#4 Updated by okurz about 1 month ago

  • Status changed from Feedback to Workable
  • Assignee deleted (okurz)

seems another error popped up in t/24-worker-jobs.t now:

[10:57:17] t/23-amqp.t ............................................... 4/? [2021-12-22 10:57:28.53092] [694] [debug] [pid:694] Sending AMQP event: some.topic
[2021-12-22 10:57:28.53200] [694] [debug] [pid:694] AMQP URL: amqp://guest:guest@localhost:5672/?exchange=pubsub&cacertfile=%2Fsome%2Fcacert.pem&certfile=%2Fsome%2Fcert.pem&keyfile=%2Fsome%2Fkey.pem
[10:57:17] t/23-amqp.t ............................................... ok    20294 ms ( 0.03 usr  0.01 sys + 19.29 cusr  0.55 csys = 19.88 CPU)
…
[10:57:49] t/24-worker-jobs.t ........................................ 1/? [WARN] Job 1 stopped because it exceeded MAX_JOB_TIME
[WARN] Found poolSAYV/base_state.json but failed to parse the JSON: 'false' expected, at character offset 0 (before "foo boo") at /usr/lib/perl5/vendor_perl/5.26.1/Mojo/JSON.pm line 31.

[10:57:49] t/24-worker-jobs.t ........................................ ok    11955 ms ( 0.09 usr  0.00 sys + 11.49 cusr  0.40 csys = 11.98 CPU)

#5 Updated by mkittler 17 days ago

  • Assignee set to mkittler

#6 Updated by mkittler 17 days ago

  • Status changed from Workable to In Progress

PR: https://github.com/os-autoinst/openQA/pull/4441

I couldn't reproduce the messages regarding signatures, though. Maybe it is already fixed. (I'll have a look at the CI output of course.)

#7 Updated by openqa_review 16 days ago

  • Due date set to 2022-01-26

Setting due date based on mean cycle time of SUSE QE Tools

#8 Updated by mkittler 16 days ago

  • Status changed from In Progress to Resolved

The signature warnings were already gone. Fixed some more unhandled output in the gru test instead. Since the PR has been merged I'm considering it resolved.

Also available in: Atom PDF