Project

General

Profile

Actions

action #103287

closed

Ensure openQA within standard repos of Leap 15.3 is working and no problem with object method "route" size:M

Added by okurz over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2021-11-30
Due date:
% Done:

0%

Estimated time:

Description

Motivation

See https://github.com/os-autoinst/os-autoinst/issues/1866

Acceptance criteria

  • AC1: openQA within standard repos of Leap 15.3 is working and no problem with object method "route" (or package does not exist in Leap 15.3)

Suggestions

  • DONE: Use any in commands.pm, already the case in current git
  • Prepare a SR to submit recent os-autoinst to Leap 15.3 if that works, otherwise backport fix
Actions #1

Updated by livdywan over 2 years ago

  • Subject changed from Ensure openQA within standard repos of Leap 15.3 is working and no problem with object method "route" to Ensure openQA within standard repos of Leap 15.3 is working and no problem with object method "route" size:M
  • Description updated (diff)
  • Status changed from New to Workable
Actions #2

Updated by okurz over 2 years ago

  • Priority changed from Normal to High
Actions #3

Updated by okurz over 2 years ago

  • Priority changed from High to Normal
Actions #4

Updated by mkittler over 2 years ago

  • Assignee set to mkittler
Actions #5

Updated by mkittler over 2 years ago

  • Status changed from Workable to Feedback
Actions #6

Updated by mkittler over 2 years ago

The MR has been accepted but the package fails to build because some of the other dependencies are now too old.

I suppose I'll have to backport https://github.com/os-autoinst/os-autoinst/commit/7aff5a55269627dc0037251c182ec4c5380baeab then.

Annoyingly, all the time when I want to branch https://build.opensuse.org/package/show/openSUSE:Leap:15.3/os-autoinst I'm now ending up branching the updated version (from my previous MR). Not sure how to branch the original version at this point. I'm also not sure how I'd revert my previous MR change.

Actions #7

Updated by okurz over 2 years ago

Huh, why was is accepted if it does not build?

Actions #8

Updated by livdywan over 2 years ago

okurz wrote:

Huh, why was is accepted if it does not build?

it does not build now I think. since you can remove links without re-building

Actions #9

Updated by mkittler over 2 years ago

Huh, why was is accepted if it does not build?

I don't know. I wouldn't have expected that.

it does not build now I think. since you can remove links without re-building

Not sure what you mean by that. Judging from the error I don't think it built before.

Actions #10

Updated by livdywan over 2 years ago

mkittler wrote:

Huh, why was is accepted if it does not build?

I don't know. I wouldn't have expected that.

it does not build now I think. since you can remove links without re-building

Not sure what you mean by that. Judging from the error I don't think it built before.

I meant that it could be broken because links changed in the meantime. But that was a thinko, there's no devel:openQA involved here where we move packages around.

What does locked mean? The logs say The Build succeeded.

Actions #11

Updated by mkittler over 2 years ago

"Locked" is the state of the current package in openSUSE:Leap:15.3 (not the update project). That current package is still from a year ago and it means that this package will stay as-is (updates will only be published to the update repo). That old version is also the version I'd like to branch for backporting (but end up branching the new version from the update project instead).

Actions #12

Updated by mkittler over 2 years ago

Note that the loose versioning constraint in the test package¹ is not ideal. It caused the test package to succeed and therefore the actual build failure was overlooked.


¹

#BuildRequires:  %{short_name} == %{version}
BuildRequires:  %{short_name}
Actions #13

Updated by mkittler over 2 years ago

I'm now trying to submit a package where I manually reverted my last change and only backported the mentioned patch: https://build.opensuse.org/request/show/940316
This one builds at least. Maybe I'll have more luck this time.

Actions #14

Updated by mkittler over 2 years ago

The SR has been accepted but now everything is unresolvable: https://build.opensuse.org/package/show/openSUSE:Maintenance:17255/os-autoinst.SUSE_SLE-15-SP3_Update

 unresolvable: nothing provides perl(Carp::Always), nothing provides perl(File::Touch), nothing provides perl(File::chdir), nothing provides perl(IPC::Run::Debug), nothing provides perl(Mojo::IOLoop::ReadWriteProcess) >= 0.26, nothing provides perl(Net::SSH2), nothing provides perl(Socket::MsgHdr), nothing provides perl(Time::Moment), nothing provides perl(XML::SemanticDiff), nothing provides perl(Test::Mock::Time), nothing provides perl(Test::MockObject), nothing provides perl(Test::MockRandom), nothing provides perl(Test::Output), nothing provides perl(Inline::Python), nothing provides perl(YAML::PP), nothing provides perl(Mojo::IOLoop::ReadWriteProcess) >= 0.28 

Not sure what to do about it. Maybe it helps to simply wait.

(https://build.opensuse.org/package/show/openSUSE:Backports:SLE-15-SP3:Update/os-autoinst has still the older version. I suppose the updated package would show up here.)

Actions #15

Updated by osukup over 2 years ago

You need update also dependencies :D and send new packages to Leap 15.3

(Can be merged as one MR)

Actions #16

Updated by mkittler over 2 years ago

So backporting a single patch is not possible? I actually wanted to avoid having to update all dependencies.

When trying to build the package locally I get the same error about unresolvable packages.

Actions #17

Updated by mkittler about 2 years ago

Note that the package is still on the version from 29-Mar-2021 (see http://download.opensuse.org/distribution/leap/15.3/repo/oss/x86_64) and https://build.opensuse.org/package/show/openSUSE:Maintenance:17255/os-autoinst.SUSE_SLE-15-SP3_Update is still unresolvable despite most "unresolvable" packages shouldn't be and I don't know why.

Actions #18

Updated by mkittler about 2 years ago

Marcus did some magic and now we're from unresolvable package to failure within the testsuite: https://build.opensuse.org/package/show/openSUSE:Maintenance:17255/os-autoinst.openSUSE_Backports_SLE-15-SP3_Update

Maybe I need to back port more patches. That's the failure:

[  189s] 3: Timeout for pipe other side helper at ./10-virtio_terminal.t line 37.
[  189s] 3: 
[  189s] 3:     #   Failed test 'no (unexpected) warnings (via END block)'
[  189s] 3:     #   at /usr/lib/perl5/5.26.1/Test/Builder.pm line 135.
[  189s] 3:     # Got the following unexpected warnings:
[  189s] 3:     #   1: Timeout for pipe other side helper at ./10-virtio_terminal.t line 37.
Actions #19

Updated by mkittler about 2 years ago

The package on https://build.opensuse.org/package/show/openSUSE:Maintenance:17255/os-autoinst.openSUSE_Backports_SLE-15-SP3_Update is actually just the to new version again. So I'm running in circles here. I doubt I can ever resolve this ticket without someone involved with OBS doing some "magic".

Actions #20

Updated by mkittler about 2 years ago

Marcus helped copying the backported version. It builds now and should move forward to Leap 15.3 update repos automatically.

Actions #21

Updated by mkittler about 2 years ago

It is still on the old version:

docker run -it registry.opensuse.org/opensuse/leap:15.3 zypper info os-autoinst
Retrieving repository 'Update repository of openSUSE Backports' metadata .............................................................................................................................................................................................................................................[done]
Building repository 'Update repository of openSUSE Backports' cache ..................................................................................................................................................................................................................................................[done]
…
Loading repository data...
Reading installed packages...


Information for package os-autoinst:
------------------------------------
Repository     : Main Repository
Name           : os-autoinst
Version        : 4.6.1606482144.ab6cdfe2-bp153.1.1
Arch           : x86_64
Vendor         : openSUSE
Installed Size : 892.7 KiB
Installed      : No
Status         : not installed
Source package : os-autoinst-4.6.1606482144.ab6cdfe2-bp153.1.1.src
Summary        : OS-level test automation
…
Actions #22

Updated by mkittler about 2 years ago

  • Status changed from Feedback to Resolved

Leap 15.3 now provides 4.6.1606482144.ab6cdfe2-bp153.2.6.1 containing the fix (checked in Leap 15.3 container). I've also been running the fullstack test within - of course the old version ab6cdfe2 and amended to use the system-provided isotovideo. It didn't pass because my amendment wasn't working perfectly (it calls isotovideo multiple times and I've just covered the first occurrence) but it got far enough to show that the problem is fixed.

Actions

Also available in: Atom PDF