Project

General

Profile

action #103002

[qe-core] test fails in openssl_nodejs SLE 15 GA and SP1

Added by mgrifalconi about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Server-DVD-Updates-aarch64-mau-extratests1@aarch64-virtio fails in
openssl_nodejs

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. Run console tests against aggregated test repo

Reproducible

Fails since (at least) Build 20211124-1

Expected result

Last good: 20211123-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by mgrifalconi about 1 year ago

Investigation:

Diff between last successful job and first failure
on 15-SP1:21118xen,21926fetchmail,21931ruby2.5,21945keyutils
on 15-GA: 21119xen,21926fetchmail,21931ruby2.5,21943suse-module-tools,21945keyutils

Will try to build an image for testing without keyutils to see if that is the cause.

Updates:

Diff between last good and first failure:

15-SP1: 21118xen,21926fetchmail,21931ruby2.5,21945keyutils
15-GA: 21119xen,21926fetchmail,21931ruby2.5,21943suse-module-tools,21945keyutils

  • Tried to build the image used for the test, without keyutils to check if it was the cause: --> Still failing
  • Tried to build the image with no updates at all: --> Still failing
  • Tried to build the last working image with no updates: --> Still failing

So I also cannot reproduce the last good run

#2 Updated by tjyrinki_suse about 1 year ago

  • Status changed from New to In Progress
  • Start date deleted (2021-11-25)

#3 Updated by coolo about 1 year ago

Well, you can stop blaming updates - the test has a deadline built in

coolo@nerissa#node-v10.24.1>openssl x509 -noout -in test/fixtures/pass-cert.pem -dates
notBefore=Nov 26 17:04:08 2011 GMT
notAfter=Nov 23 17:04:08 2021 GMT

#4 Updated by mgrifalconi about 1 year ago

  • Category deleted (Bugs in existing tests)
  • Assignee deleted (mgrifalconi)

Great finding! Thanks coolo !
Will disable the single failing test for now to unblock updates and open a bug for it!

#5 Updated by mgrifalconi about 1 year ago

  • Category set to Bugs in existing tests
  • Assignee set to mgrifalconi

#7 Updated by mgrifalconi about 1 year ago

  • Status changed from In Progress to Feedback
  • Priority changed from High to Normal

Test was removed, updates on openqa are no longer blocked.

Keeping open on Feedback since I am waiting on info from Adam about the topic, since Nodejs10 is not supported upstream, the fix needs to be done in-house.

#8 Updated by mgrifalconi 11 months ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Should be all fixed now.

Also available in: Atom PDF