Project

General

Profile

action #102269

QA - coordination #91646: [saga][epic] SUSE Maintenance QA workflows with fully automated testing, approval and release

openQABot pipeline failed with HTTP 403

Added by cdywan 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Target version:
Start date:
2021-11-11
Due date:
% Done:

0%

Estimated time:

Description

Observation

The openQABot pipeline failed with a HTTP 403 error:

++ ./oqabot.py --verbose --only-l3
47++ tee openqabot.log
48INFO: Working on incident: PTF:22097
49INFO: Posting 0 jobs
50INFO: Project PTF:22097 without jobs -- adding a comment that there will be no tests
[...]
  File "/builds/x241SkZb/0/qa-maintenance/openQABot/openqabot/osclib/comments.py", line 232, in delete
65    return http_DELETE(url)
66  File "/usr/lib/python3.6/site-packages/osc/core.py", line 3424, in http_DELETE
[...]
76  File "/usr/lib64/python3.6/urllib/request.py", line 570, in error
77    return self._call_chain(*args)
78  File "/usr/lib64/python3.6/urllib/request.py", line 504, in _call_chain
79    result = func(*args)
80  File "/usr/lib64/python3.6/urllib/request.py", line 650, in http_error_default
81    raise HTTPError(req.full_url, code, msg, hdrs, fp)
82urllib.error.HTTPError: HTTP Error 403: Forbidden

Related issues

Copied to openQA Infrastructure - action #102284: openQABot pipeline failed with simplejson.errors.JSONDecodeError: Expecting value: line 1 column 1 (char 0) Resolved2021-11-11

History

#1 Updated by okurz 3 months ago

  • Priority changed from Normal to Low
  • Target version set to future
  • Parent task set to #80194

#2 Updated by jbaier_cz 3 months ago

  • Status changed from New to Closed

Caused by Ondrej running the bot manually (and creating a comment the bot cannot delete).

#3 Updated by cdywan 3 months ago

  • Copied to action #102284: openQABot pipeline failed with simplejson.errors.JSONDecodeError: Expecting value: line 1 column 1 (char 0) added

#4 Updated by okurz 3 months ago

  • Status changed from Closed to Resolved
  • Assignee set to osukup

Let's be gracious and call it "fixed" ;)

Also available in: Atom PDF