Project

General

Profile

action #102284

QA - coordination #91646: [saga][epic] SUSE Maintenance QA workflows with fully automated testing, approval and release

openQABot pipeline failed with simplejson.errors.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

Added by cdywan 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
2021-11-11
Due date:
% Done:

0%

Estimated time:

Description

Observation

The openQABot pipeline failed with a JSONDecodeError exception:

++ tee openqabot.log
43++ ./oqabot.py --verbose --only-mr --metadata /etc/openqabot/mr.yml
44Traceback (most recent call last):
45  File "./oqabot.py", line 27, in <module>
46    main()
47  File "/builds/wxDU3Xwr/0/qa-maintenance/openQABot/openqabot/main.py", line 18, in main
48    sys.exit(run_bot(logger, args, sys))
49  File "/builds/wxDU3Xwr/0/qa-maintenance/openQABot/openqabot/main.py", line 41, in run_bot
50    return OpenQABot(metadata, args)()
51  File "/builds/wxDU3Xwr/0/qa-maintenance/openQABot/openqabot/openqabot.py", line 77, in __init__
52    self.mrs = MR(args.smelt, args.base_url, args.commenter)()
53  File "/builds/wxDU3Xwr/0/qa-maintenance/openQABot/openqabot/update/mr.py", line 23, in __call__
54    return self._get_mr_data()
55  File "/builds/wxDU3Xwr/0/qa-maintenance/openQABot/openqabot/update/mr.py", line 144, in _get_mr_data
56    ids = self._get_mr_ids()
57  File "/builds/wxDU3Xwr/0/qa-maintenance/openQABot/openqabot/update/mr.py", line 85, in _get_mr_ids
58    self.smelt, params={"query": query}, verify=False
59  File "/usr/lib/python3.6/site-packages/requests/models.py", 
[...]
  File "/usr/lib64/python3.6/site-packages/simplejson/decoder.py", line 370, in decode
64    obj, end = self.raw_decode(s)
65  File "/usr/lib64/python3.6/site-packages/simplejson/decoder.py", line 400, in raw_decode
66    return self.scan_once(s, idx=_w(s, idx).end())
67simplejson.errors.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

Related issues

Copied from openQA Infrastructure - action #102269: openQABot pipeline failed with HTTP 403Resolved2021-11-11

History

#1 Updated by cdywan 2 months ago

  • Copied from action #102269: openQABot pipeline failed with HTTP 403 added

#2 Updated by okurz 2 months ago

  • Target version changed from Ready to future

I suggest you follow the ticket template from https://progress.opensuse.org/projects/openqav3/wiki/#Defects , e.g. if this is reproducible. Until then not including in backlog.

#3 Updated by osukup 2 months ago

caused by malformed reply from SMELT ...

#4 Updated by okurz 2 months ago

  • Assignee set to osukup
  • Target version changed from future to Ready

+1

#5 Updated by osukup 2 months ago

  • Status changed from New to Feedback

better catch of error was merged ... now it logs exception and failed query, then gracefuly end with exit code 1..

error caused by malformed reply from SMELT ( non responding api ..?)

so now for feedback

#6 Updated by osukup about 1 month ago

  • Status changed from Feedback to Resolved

seems like SMELT responses are for long time proper

Also available in: Atom PDF