Project

General

Profile

action #99489

qa-maintenance/openQABot CI job fails on `TypeError: 'NoneType' object is not subscriptable`

Added by okurz 4 months ago. Updated 4 months ago.

Status:
Rejected
Priority:
Low
Assignee:
Target version:
Start date:
2021-09-29
Due date:
% Done:

0%

Estimated time:

Description

Observation

https://gitlab.suse.de/qa-maintenance/openQABot/-/jobs/614922 fails with

$ /usr/bin/oqaqambot --verbose $BOT_PARAMS 2>&1 | tee openqabot.log
Traceback (most recent call last):
  File "/usr/bin/oqaqambot", line 11, in <module>
    load_entry_point('openQABot==0.3.0', 'console_scripts', 'oqaqambot')()
  File "/usr/lib/python3.6/site-packages/openqabot/main.py", line 18, in main
    sys.exit(run_bot(logger, args, sys))
  File "/usr/lib/python3.6/site-packages/openqabot/main.py", line 41, in run_bot
    return OpenQABot(metadata, args)()
  File "/usr/lib/python3.6/site-packages/openqabot/openqabot.py", line 88, in __init__
    self.mrs = MR(args.smelt, args.base_url, args.commenter)()
  File "/usr/lib/python3.6/site-packages/openqabot/update/mr.py", line 23, in __call__
    return self._get_mr_data()
  File "/usr/lib/python3.6/site-packages/openqabot/update/mr.py", line 138, in _get_mr_data
    return self._get_mr_requests(ids)
  File "/usr/lib/python3.6/site-packages/openqabot/update/mr.py", line 124, in _get_mr_requests
    for r in ret
  File "/usr/lib/python3.6/site-packages/openqabot/update/mr.py", line 126, in <listcomp>
    and "MAINTENANCE_REQUEST" in r["requestactionSet"][0]["srcProject"]["name"]
TypeError: 'NoneType' object is not subscriptable

Reproducible

the next job
https://gitlab.suse.de/qa-maintenance/openQABot/-/jobs/615058
has passed

Suggestion

  • Monitor. As long as this does not happen again, don't care about it

Related issues

Is duplicate of QA - action #97955: [openqabot] Possible TypeError during execution "'NoneType' object is not subscriptable"Resolved2021-09-02

History

#1 Updated by jbaier_cz 4 months ago

This seems like a "bad" response from the smelt. Probably an issue with one of the incidents, so it is data releated.

#2 Updated by jbaier_cz 4 months ago

  • Is duplicate of action #97955: [openqabot] Possible TypeError during execution "'NoneType' object is not subscriptable" added

#3 Updated by okurz 4 months ago

  • Status changed from New to Rejected
  • Assignee set to okurz

rejecting in favor of original #97955 . I agree with the suggestion in #97955#note-1 to have better exception handling, shouldn't be too hard.

Also available in: Atom PDF