Project

General

Profile

action #98243

salt-states-openqa pipeline/job "test-worker" fails because zypper reports an error size:M

Added by nicksinger about 1 month ago. Updated about 1 month ago.

Status:
Rejected
Priority:
High
Assignee:
-
Target version:
Start date:
2021-09-07
Due date:
% Done:

0%

Estimated time:

Description

Observation

It seems that recently our pipeline started to fail. Example: https://gitlab.suse.de/openqa/salt-states-openqa/-/jobs/557702#L8526

Steps to reproduce

I was not able to reproduce this manually in a podman-container running on my workstation so I assume this has something to do with a change with our gitlab runners.

Problem

The failed testcases all include one of the following 2 comments:

  • One or more requisite failed: openqa.worker.worker-openqa.packages
  • User openvswitch is not available Group openvswitch is not available
  • /etc/logrotate.d/openvswitch: file not found
  • An error was encountered while installing package(s): Zypper command failure: Check Zypper's logs.

Judging by the last one, it may be the cause of the previous ones. It is the first error that is encountered.

Suggestion

  • Check if the only problem is the zypper failure in the begining
  • Can we retry the package installation in salt? (check salt docs)
  • Can we retry the pipeline conditionally? (last resort)

History

#1 Updated by VANASTASIADIS about 1 month ago

  • Description updated (diff)

#2 Updated by cdywan about 1 month ago

These looks like different issues to me:

#3 Updated by cdywan about 1 month ago

  • Subject changed from salt-states-openqa pipeline/job "test-worker" fails because zypper reports an error to salt-states-openqa pipeline/job "test-worker" fails because zypper reports an error size:M
  • Description updated (diff)
  • Status changed from New to Workable
  • Target version set to Ready

#4 Updated by nicksinger about 1 month ago

Since I couldn't reproduce locally I restarted the job of the pipeline for my MR at https://gitlab.suse.de/nicksinger/salt-states-openqa/-/pipelines/197290 and realized that it succeeded this time. I just restarted the same job for a different pipeline (https://gitlab.suse.de/nicksinger/salt-states-openqa/-/pipelines/197287) - if this also completes now I think we can reject this bug and assume we had some issue in our gitlab runner infrastructure.

#5 Updated by nicksinger about 1 month ago

  • Status changed from Workable to Rejected

Apparently the underlying issue got fixed as https://gitlab.suse.de/nicksinger/salt-states-openqa/-/pipelines/197287 also completed successfully. I couldn't find any hint what was changed which is kind of frustrating to just close a ticket as "now it works again". But well, at least MRs can be merged again with proper testing :)

Also available in: Atom PDF