Project

General

Profile

action #97709

[sporadic] accept_timezone_configuration fails to navigate next screen

Added by syrianidou_sofia about 2 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
High
Target version:
Start date:
2021-08-30
Due date:
% Done:

0%

Estimated time:

Description

Even though, the yui logs show that next was pressed after the timezone module was shown, the installation doesn't proceed as expected. This happens sporadically. We need to investigate if indeed the button is not pressed or if it takes too long for the next screen to appear and fix the issue accordingly.

Observation

openQA test in scenario sle-15-SP4-Online-ppc64le-multipath@ppc64le-no-tmpfs fails in
hostname_inst

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. Maintainer: QE Yast

Test installation on machine with virtual multipath hardware. Only tests succesful detection of multipath and installation. No functional testing of multipath itself.

Reproducible

Fails since (at least) Build 29.1 (current job)

Expected result

Last good: 26.1 (or more recent)

Further details

Always latest result in this scenario: latest

Suggestion

Most likely the button was pressed but the screen takes some time to load, we can see here the time zone combobox is still not loaded, so we could be more strict in is_shown() method of the screen.

History

#1 Updated by syrianidou_sofia about 2 months ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Bugs in existing tests)
  • Target version set to Current

#2 Updated by JERiveraMoya about 2 months ago

  • Description updated (diff)

#3 Updated by JERiveraMoya about 2 months ago

  • Subject changed from [sporadic] accept_timezone_configuration fails to succesfully press next to [sporadic] accept_timezone_configuration fails to navigate next screen

#4 Updated by JERiveraMoya about 2 months ago

  • Status changed from New to Workable
  • Priority changed from Normal to High

#5 Updated by syrianidou_sofia about 2 months ago

  • Status changed from Workable to In Progress
  • Assignee set to syrianidou_sofia

#7 Updated by syrianidou_sofia about 1 month ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF