Project

General

Profile

action #97331

[timebox: 24h] Investigate failure in rebootmgr

Added by syrianidou_sofia about 2 months ago. Updated 28 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
2021-08-22
Due date:
% Done:

0%

Estimated time:

Description

The transactional server cannot reconnect to redcurrant-* via rebootmgr. Not sure if related but "--no-selfupdate" option is missing from command https://openqa.suse.de/tests/6914085#step/rebootmgr/6
We need to check if the update before reconnection is causing the connection issue, if not, try to find the problem.

Observation

openQA test in scenario sle-15-SP4-Online-ppc64le-transactional_server_helper_apps@ppc64le-hmc-single-disk fails in
rebootmgr

Test suite description

Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml. Test transactional updates with Btrfs and helper applications in a transactional update server.

Reproducible

Fails since (at least) Build 18.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #98832: [y][yast][qac][container][powerVM] rebootmgr fails in PowerVM reconnecting after rebootNew2021-09-17

History

#1 Updated by syrianidou_sofia about 2 months ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (Bugs in existing tests)

#2 Updated by JERiveraMoya about 2 months ago

  • Target version set to Current

#3 Updated by JERiveraMoya about 2 months ago

  • Subject changed from test fails in rebootmgr to Investigate failure in rebootmgr

#4 Updated by JERiveraMoya about 2 months ago

  • Status changed from New to In Progress
  • Assignee set to JERiveraMoya

#5 Updated by JERiveraMoya about 2 months ago

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/13135
cannot reach that module 'yet' but the problem might be cause by different logic introduced a time ago for PowerVM.

#6 Updated by JERiveraMoya about 2 months ago

  • Status changed from In Progress to Feedback

#7 Updated by JERiveraMoya about 1 month ago

  • Status changed from Feedback to In Progress

#8 Updated by JERiveraMoya about 1 month ago

Finally we found that there were recent changes in transactional source code since May, where approximately started to fail, I'm going to try to revert them to check if they are the cause of the failure.
One example of PR on that time, but there are more than this one: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/12547/files

#9 Updated by JERiveraMoya about 1 month ago

@vogtinator gave us some hints, I will try with next build, I could not reproduce it, once I revert some code I got failure in previous test modules, and due it is powerVM and there is not booting from snaphshot takes a lot of time to reproduce it.

#10 Updated by JERiveraMoya 28 days ago

  • Subject changed from Investigate failure in rebootmgr to [timebox: 24h] Investigate failure in rebootmgr

#11 Updated by JERiveraMoya 28 days ago

  • Status changed from In Progress to Closed

After investigation, created: https://progress.opensuse.org/issues/98832

#12 Updated by JERiveraMoya 28 days ago

  • Related to action #98832: [y][yast][qac][container][powerVM] rebootmgr fails in PowerVM reconnecting after reboot added

Also available in: Atom PDF