Project

General

Profile

Actions

action #95290

closed

error in openqa-webui systemd service log "Mojo::Reactor::Poll: Timer failed: Can't open file "/tmp/RbB4AGlDAq/": No such file or directory at /usr/share/openqa/script/../lib/OpenQA/WebAPI/Controller/Running.pm line 211."

Added by okurz almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2021-07-09
Due date:
2021-07-24
% Done:

0%

Estimated time:

Description

Observation

From ssh o3 "sudo journalctl --since=today -u openqa-webui"

Jul 09 08:29:57 ariel openqa-webui-daemon[31522]: Mojo::Reactor::Poll: Timer failed: Can't open file "/tmp/RbB4AGlDAq/": No such file or directory at /usr/share/openqa/script/../lib/OpenQA/WebAPI/Controller/Running.pm line 211.
…
Jul 09 08:31:26 ariel openqa-webui-daemon[31522]: Mojo::Reactor::Poll: Timer failed: Can't open file "/tmp/RbB4AGlDAq/": No such file or directory at /usr/share/openqa/script/../lib/OpenQA/WebAPI/Controller/Running.pm line 211.

spamming the log multiple entries per second

Actions #1

Updated by mkittler almost 3 years ago

  • Assignee set to mkittler
Actions #2

Updated by mkittler almost 3 years ago

  • Priority changed from Urgent to High

It has only been logged from Jul 09 08:27:07 to Jul 09 08:31:26 and only for the same job. (The temporary directory is always the same and one temp dir corresponds to one job.)

This code is responsible for updating the latest image within the live view. Hence it is repeated frequently but it doesn't mean the impact is very high.

Actions #3

Updated by mkittler almost 3 years ago

  • Status changed from New to In Progress
Actions #4

Updated by okurz almost 3 years ago

mkittler wrote:

It has only been logged from Jul 09 08:27:07 to Jul 09 08:31:26 and only for the same job. (The temporary directory is always the same and one temp dir corresponds to one job.)

ok, and where are the logs from in before? I assume the impact could be grave because if the log fills up with just a single message we don't have logs going back further in the past which can drop on our feet as soon as the next bigger issue hits us

Actions #5

Updated by openqa_review almost 3 years ago

  • Due date set to 2021-07-24

Setting due date based on mean cycle time of SUSE QE Tools

Actions #6

Updated by mkittler almost 3 years ago

the log fills up with just a single message we don't have logs going back further in the past which can drop on our feet as soon as the next bigger issue hits us

When doing further in the past it becomes apparent that it is more than just one job.

I've been updating the PR so it should be mergble soon anyways.

Actions #7

Updated by mkittler almost 3 years ago

  • Status changed from In Progress to Feedback

PR has been merged, let's see whether it works in production. Not sure why the error condition is hit in the first place, though.

Actions #8

Updated by mkittler over 2 years ago

  • Status changed from Feedback to Resolved

sudo journalctl --no-pager -u openqa-webui | grep -i 'Mojo::Reactor::Poll' shows no further log messages after Jul 14 (the day the PR has been merged). The same counts for OSD except that we never saw the error there in the first place. The live view still works.

Actions

Also available in: Atom PDF