Project

General

Profile

action #93393

backend died: Virtio terminal and svirt serial terminal do not support send_key

Added by ph03nix about 2 months ago. Updated about 2 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2021-06-02
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

A test failure in sle-15-SP2-Server-DVD-Updates-x86_64-Build20210602-1-sle_image_on_sle_host@64bit triggers a backend failure in qemu, rendering the whole scenario incomplete.

Problem

Distribution uses send_key, which seems to not be supported in virtio terminal

Impact

For now this is nothing serious, however it breaks the whole test scenario and reduces coverage, as follow-up tests are not executed anymore. For now not a problem but it might become one in the future and for other test scenarios.


Related issues

Is duplicate of openQA Project - action #80778: job incompletes with "Virtio terminal and svirt serial terminal do not support send_key", we should change the reason message to be ignored by auto-review, but be clear for the test maintainerWorkable2020-12-07

History

#1 Updated by VANASTASIADIS about 2 months ago

  • Target version set to future

#2 Updated by VANASTASIADIS about 2 months ago

  • Related to action #80778: job incompletes with "Virtio terminal and svirt serial terminal do not support send_key", we should change the reason message to be ignored by auto-review, but be clear for the test maintainer added

#3 Updated by VANASTASIADIS about 2 months ago

  • Related to deleted (action #80778: job incompletes with "Virtio terminal and svirt serial terminal do not support send_key", we should change the reason message to be ignored by auto-review, but be clear for the test maintainer)

#4 Updated by VANASTASIADIS about 2 months ago

  • Is duplicate of action #80778: job incompletes with "Virtio terminal and svirt serial terminal do not support send_key", we should change the reason message to be ignored by auto-review, but be clear for the test maintainer added

#5 Updated by VANASTASIADIS about 2 months ago

  • Status changed from New to Rejected

This is expected behavior, there is an issue open about this, see #80778. The test code maintainer should adjust the code accordingly.

Also available in: Atom PDF