Project

General

Profile

action #93339

test fails in validate_btrfs

Added by jlausuch 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-06-01
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP3-Server-DVD-Updates-x86_64-sle_image_on_sle_host@64bit fails in
validate_btrfs
Other failures:
All Container jobs, e.g. https://openqa.suse.de/tests/6151606
All Public Cloud jobs, e.g. https://openqa.suse.de/tests/6149926#step/validate_btrfs/39

Test suite description

The base test suite is used for job templates defined in YAML documents. It has no settings of its own.

Reproducible

Fails since (at least) Build 20210601-1 (current job)

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by ph03nix 5 months ago

  • Assignee set to ph03nix

#2 Updated by ph03nix 5 months ago

Looking at https://openqa.suse.de/tests/6151606#step/validate_btrfs/38 the issue appears to me to be an erroneous validation regex:

validate_script_output got:
Data, single: total=4.01GiB, used=3.05GiB
System, DUP: total=32.00MiB, used=16.00KiB
Metadata, DUP: total=1.25GiB, used=77.97MiB
GlobalReserve, single: total=7.25MiB, used=0.00B

Check function (deparsed code):
{
    package validate_btrfs;
    use feature 'current_sub', 'evalbytes', 'fc', 'say', 'state', 'switch', 'unicode_strings', 'unicode_eval';
    /^Data.+total=[12].*GiB, used=\d+.+[KM]iB/u;
}

Because the output is something like used=...GiB but the regex only matches [KM]iB, so GiB is not included.

#5 Updated by ph03nix 5 months ago

ph03nix wrote:

Test run: http://duck-norris.qam.suse.de/t6550

Multiple regexes across the whole test are just wrong, because the hard disk size doesn't match the test requirements.

https://openqa.suse.de/tests/6151606#dependencies inherits the image from https://openqa.suse.de/tests/6149112 where HDDSIZEGB=40

#7 Updated by ph03nix 5 months ago

Merged

#8 Updated by ph03nix 5 months ago

Two failures: 15-SP3 and 12-SP4

For the 15-SP3 failure, because they are using a custom CASEDIR setting and not the fixed upstream variant there is little that we can do now.

The 12-SP4 fails, because btrfs balance fails due to the disk being too full. Working on a fix now.

#9 Updated by ph03nix 5 months ago

  • % Done changed from 80 to 90

#10 Updated by ph03nix 5 months ago

  • Status changed from Workable to Resolved
  • % Done changed from 90 to 100

#11 Updated by jlausuch 4 months ago

I missed thanking you for this!

#12 Updated by ph03nix 4 months ago

jlausuch wrote:

I missed thanking you for this!

Was a pleasure ;-)

Also available in: Atom PDF