Project

General

Profile

action #92512

[qe-core][qem] Package 'mdadm-4.1-15.20.1' not found.

Added by dzedro 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2021-05-11
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

mdadm version 4.1-15.20.1 is too low on 15 SP3

openQA test in scenario sle-15-SP3-Server-DVD-Updates-x86_64-mau-qa_userspace_systemd@64bit fails in
userspace_systemd

Test suite description

Reproducible

Fails since (at least) Build 20210505-1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by geor 3 months ago

  • Status changed from New to Workable
  • % Done changed from 0 to 30

Ok so the problem is that without the old version the job will fail

This is because, in the newer versions, mdadm exits immediately if no md device is configured
So the solution seemed simple enough, to create a raid array so that the test does not fail.
However even with an md0 device setup and the relevant config, mdadm --monitor -d 60 -m root@localhost --scan -c /etc/mdadm.conf still does not want to monitor and exits. So it looks like there is something not right with the newer mdadm version.

I will follow up on the bug bug tomorrow, and take it from there.

#2 Updated by geor 3 months ago

  • % Done changed from 30 to 40

#3 Updated by geor 3 months ago

  • Status changed from Workable to In Progress

Working on fix

#4 Updated by geor 3 months ago

  • Target version set to QE-Core: Ready

#6 Updated by geor 2 months ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

PR merged

Also available in: Atom PDF