Project

General

Profile

action #91491

potential performance regression, failures in os-autoinst t/18-qemu-options.t

Added by okurz over 1 year ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2021-04-21
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

https://github.com/os-autoinst/os-autoinst/pull/1652/checks?check_run_id=2399230336#step:3:539 fails in an unrelated PR with

6:     #   Failed test 'execution time of isotovideo (24.5780038833618 s) within reasonable limits'
6:     #   at ./18-qemu-options.t line 87.
6:     #     '24.5780038833618'
6:     #         <
6:     #     '24'
6:     # Looks like you failed 1 test of 16.
6: 
6: #   Failed test 'qemu_append_option'
6: #   at ./18-qemu-options.t line 110.

24s is long enough. We should crosscheck the current performance.

Expected result

  • 18-qemu-options.t should be able to execute well below 24s in general

Suggestions

  • Run os-autoinst t/18-qemu-options.t in a consisten environment multiple times and derive if there is a performance regression
  • Try to identify which part takes longer now

History

#1 Updated by okurz over 1 year ago

  • Target version changed from Ready to future

#2 Updated by cdywan about 2 months ago

If I never see this fail locally or in CI does it mean it's resolved?

#3 Updated by okurz about 2 months ago

  • Status changed from Workable to Resolved
  • Assignee set to okurz
  • Target version changed from future to Ready

yes, I think so. I ran runs=500 count_fail_ratio prove -I. t/18-qemu-options.t without problems and the runtime being in the range of 4-6s so all good.

Also available in: Atom PDF